Bug 1008584 - Convert from war to ear
Convert from war to ear
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: redhat-support-plugin-rhev (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Spenser Shumaker
Jiri Belka
subeng
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 12:08 EDT by Keith Robertson
Modified: 2016-07-03 21:34 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Currently, the plug-in is installed as a WAR file. This was done in 3.2.x because engine and the installer didn't facilitate installation as a co-requisite ear. As a result, modififications to application.xml in %pre/%post RPM scripts had to be made. An EAR is now installed alongside the manager ear.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:58:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Robertson 2013-09-16 12:08:49 EDT
Description of problem:
Currently, the plug-in is installed as a WAR file.  This was done in 3.2.x because engine and the installer didn't facilitate installation as a co-requisite ear.

As a result, we must modify application.xml in %pre/%post RPM scripts.  This is sub-optimal but, is the only way to accomplish the goal.

In 3.3 and forward we believe it may be possible to install as an EAR alongside the RHEV-M ear.  This bug tracks this effort.
Comment 1 Itamar Heim 2013-09-29 03:09:43 EDT
keith - is this slated for 3.3? starting to be late if not in testing "right now"?
Comment 2 Keith Robertson 2013-10-03 10:28:32 EDT
We're done.  Please provide 3.3 QA ACK so that we can get an official build out.
Comment 4 Jiri Belka 2013-10-07 06:14:49 EDT
OK, redhat-support-plugin-rhev-3.3.0-8.el6ev.
Comment 5 Charlie 2013-11-27 20:34:08 EST
This bug is currently attached to errata RHBA-2013:15513. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 6 errata-xmlrpc 2014-01-21 11:58:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0082.html

Note You need to log in before you can comment on or make changes to this bug.