Bug 1008675 - (intermittent) creation volume of type "distributed stripe" gets detected as stripe volume
(intermittent) creation volume of type "distributed stripe" gets detected as ...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity high
: ---
: RHGS 2.1.2
Assigned To: Kanagaraj
Dustin Tsang
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 16:03 EDT by Dustin Tsang
Modified: 2016-04-18 06:06 EDT (History)
11 users (show)

See Also:
Fixed In Version: CB10
Doc Type: Bug Fix
Doc Text:
Previously, creation of distributed-stripe volume with 8 bricks was identified and displayed as 'stripe' volume type in Volumes tab and General sub-tab of Volumes tab. Now, the volume types are identified and displayed correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:38:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm log (1.67 MB, text/x-log)
2013-09-16 16:12 EDT, Dustin Tsang
no flags Details
engine log (7.47 MB, text/x-log)
2013-09-16 16:13 EDT, Dustin Tsang
no flags Details

  None (edit)
Description Dustin Tsang 2013-09-16 16:03:43 EDT
Description of problem:
A volume created as a "distributed stripe" volume gets recognized by rhsc as a "stripe" volume.

volume type recognition is also an issue for "distributed-replicate" volumes


Version-Release number of selected component (if applicable):
rhsc-bb10
u6 and rhs 2.1 nodes.

How reproducible:
50% of the time

Steps to Reproduce:
1. in the gui create 2 host cluster
2. create a 2x4 distributed stripe volume with the stripe count set to 4

Actual results:
In the volume, main tab, the table displays "stripe" as the volume type for the volume. Selecting the volume opens the general sub-tab for the volume. The general sub-tab shows "stripe" as the volume type.

Expected results:
main tab and general sub-tab for volume should show "distributed stripe" for the volume type.

Additional info:
Comment 1 Dustin Tsang 2013-09-16 16:05:38 EDT
gluster cli shows that the volume was correctly created by rhsc:



[root@dhcp159-176 ~]# gluster volume info
 
Volume Name: automation-volume-distributed-stripe
Type: Distributed-Stripe
Volume ID: d0aa2b7b-da35-4d45-a5a1-583efd6fa700
Status: Created
Number of Bricks: 2 x 4 = 8
Transport-type: tcp
Bricks:
Brick1: latest-anshi-a:/rhs/brick1/gluster/bricks/distributedStripe/brick1
Brick2: latest-anshi-a:/rhs/brick1/gluster/bricks/distributedStripe/brick2
Brick3: latest-anshi-a:/rhs/brick1/gluster/bricks/distributedStripe/brick3
Brick4: latest-anshi-a:/rhs/brick1/gluster/bricks/distributedStripe/brick4
Brick5: latest-anshi-b:/rhs/brick1/gluster/bricks/distributedStripe/brick1
Brick6: latest-anshi-b:/rhs/brick1/gluster/bricks/distributedStripe/brick2
Brick7: latest-anshi-b:/rhs/brick1/gluster/bricks/distributedStripe/brick3
Brick8: latest-anshi-b:/rhs/brick1/gluster/bricks/distributedStripe/brick4
Options Reconfigured:
auth.allow: 10.70.35.63,10.70.35.123
user.cifs: disable
nfs.disable: off
[root@dhcp159-176 ~]
Comment 2 Dustin Tsang 2013-09-16 16:12:22 EDT
Created attachment 798415 [details]
vdsm log
Comment 3 Dustin Tsang 2013-09-16 16:13:46 EDT
Created attachment 798416 [details]
engine log
Comment 5 Dustin Tsang 2013-12-09 13:28:57 EST
verified in rhsc-cb10
Comment 6 Shalaka 2014-01-21 03:23:04 EST
Please review the edited DocText and signoff.
Comment 7 Kanagaraj 2014-01-21 03:26:10 EST
doc_text looks good.
Comment 9 errata-xmlrpc 2014-02-25 02:38:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.