Bug 1008695 - [abrt] yum-utils-1.1.31-17.fc19: tupledealloc: Process /usr/bin/python2.7 was killed by signal 11 (SIGSEGV)
[abrt] yum-utils-1.1.31-17.fc19: tupledealloc: Process /usr/bin/python2.7 was...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
abrt_hash:622b448b1f10fec396728628d1b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 17:30 EDT by David Timms
Modified: 2014-06-04 11:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-04 11:28:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (31.43 KB, text/plain)
2013-09-16 17:30 EDT, David Timms
no flags Details
File: cgroup (140 bytes, text/plain)
2013-09-16 17:30 EDT, David Timms
no flags Details
File: core_backtrace (10.63 KB, text/plain)
2013-09-16 17:30 EDT, David Timms
no flags Details
File: dso_list (9.80 KB, text/plain)
2013-09-16 17:30 EDT, David Timms
no flags Details
File: environ (2.44 KB, text/plain)
2013-09-16 17:31 EDT, David Timms
no flags Details
File: limits (1.29 KB, text/plain)
2013-09-16 17:31 EDT, David Timms
no flags Details
File: maps (46.68 KB, text/plain)
2013-09-16 17:31 EDT, David Timms
no flags Details
File: open_fds (1.79 KB, text/plain)
2013-09-16 17:31 EDT, David Timms
no flags Details
File: proc_pid_status (910 bytes, text/plain)
2013-09-16 17:31 EDT, David Timms
no flags Details
File: var_log_messages (691 bytes, text/plain)
2013-09-16 17:31 EDT, David Timms
no flags Details

  None (edit)
Description David Timms 2013-09-16 17:30:32 EDT
Description of problem:
There is a bug in acpid - package, where it wont uninstall properly when it gets upgraded. This leads to having two acpid packages installed.

  Ran:
package-cleanup --dupes
  which showed the duplicate packages
package-cleanup --cleandupes
  which appeared to work, although the pre/post script generated some errors. The result was similar to:
acpid 
complete
then the fault occurred before the command prompt was shown.
( I have had other similar weird errors lately, and saw this bug report, which was quickly dismissed:
https://bugzilla.redhat.com/show_bug.cgi?id=1005507

Version-Release number of selected component:
yum-utils-1.1.31-17.fc19

Additional info:
reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        /usr/bin/python /bin/debuginfo-install update ffmpeg-compat
crash_function: tupledealloc
executable:     /usr/bin/python2.7
kernel:         3.10.11-200.fc19.x86_64
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 tupledealloc at /usr/src/debug/Python-2.7.5/Objects/tupleobject.c:238
 #1 list_dealloc at /usr/src/debug/Python-2.7.5/Objects/listobject.c:318
 #2 dict_dealloc at /usr/src/debug/Python-2.7.5/Objects/dictobject.c:1019
 #3 instance_dealloc at /usr/src/debug/Python-2.7.5/Objects/classobject.c:681
 #4 insertdict_by_entry at /usr/src/debug/Python-2.7.5/Objects/dictobject.c:528
 #5 dict_set_item_by_hash_or_entry at /usr/src/debug/Python-2.7.5/Objects/dictobject.c:774
 #6 PyDict_SetItem at /usr/src/debug/Python-2.7.5/Objects/dictobject.c:827
 #7 _PyObject_GenericSetAttrWithDict at /usr/src/debug/Python-2.7.5/Objects/object.c:1529
 #8 PyObject_SetAttr at /usr/src/debug/Python-2.7.5/Objects/object.c:1252
 #9 PyEval_EvalFrameEx at /usr/src/debug/Python-2.7.5/Python/ceval.c:2078
Comment 1 David Timms 2013-09-16 17:30:39 EDT
Created attachment 798425 [details]
File: backtrace
Comment 2 David Timms 2013-09-16 17:30:44 EDT
Created attachment 798426 [details]
File: cgroup
Comment 3 David Timms 2013-09-16 17:30:51 EDT
Created attachment 798427 [details]
File: core_backtrace
Comment 4 David Timms 2013-09-16 17:30:56 EDT
Created attachment 798428 [details]
File: dso_list
Comment 5 David Timms 2013-09-16 17:31:03 EDT
Created attachment 798429 [details]
File: environ
Comment 6 David Timms 2013-09-16 17:31:08 EDT
Created attachment 798430 [details]
File: limits
Comment 7 David Timms 2013-09-16 17:31:24 EDT
Created attachment 798431 [details]
File: maps
Comment 8 David Timms 2013-09-16 17:31:29 EDT
Created attachment 798432 [details]
File: open_fds
Comment 9 David Timms 2013-09-16 17:31:34 EDT
Created attachment 798433 [details]
File: proc_pid_status
Comment 10 David Timms 2013-09-16 17:31:42 EDT
Created attachment 798434 [details]
File: var_log_messages

Note You need to log in before you can comment on or make changes to this bug.