Bug 100876 - pcnet32 network card stops functioning after installation
pcnet32 network card stops functioning after installation
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2003-07-26 09:06 EDT by Carl T. Miller
Modified: 2015-01-04 17:02 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-08-25 12:01:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Carl T. Miller 2003-07-26 09:06:24 EDT
Description of problem:
After doing a network install and rebooting, the network card stops
functioning.  The card is identified as a 79c970 [PCnet32 LANCE] with
no IRQ or I/O in redhat-config-network.  Running ifconfig shows IRQ 10
and I/O 0x10e0.  Trying to restart network services gives this error
message: Determining IP information for eth0... failed; no link present.
Check cable?

Version-Release number of selected component (if applicable):

How reproducible:
It happened both times I installed.

Steps to Reproduce:
1.  Install severn
2.  Reboot after installation is completed
Actual results:
Network card fails to function

Expected results:
Network card functions normally

Additional info:
This is happening in a virtual machine using VMware.  I have several
virtual machines with several different OSes, and this is the only
VM I've had a network problem with.

BTW, I've tried using rmmod and modprobe to reload the driver.  Same
results.  I've tried adding the IRQ and I/O in the redhat-config-network
dialog, and that makes it worse, since I got error messages about not
being able to load the module because of incorrect parameters.  I also
tried removing the network card section from /etc/sysconfig/hwconf just
to see if the card gets rediscovered upon reboot.  Kudzu didn't discover
it but the module was loaded anyway with the same symptoms as before.
Comment 1 Bill Nottingham 2003-07-28 17:04:34 EDT
vmware's network driver is buggy in respect to link status.
Comment 2 Carl T. Miller 2003-07-28 19:41:46 EDT
I'm surprised that you closed this so rapidly.  I've installed various
other releases of Red Hat and other Linux distributions in VMWare virtual 
machines without any problems.  From what I've seen the network driver
only fails in severn.

Aren't you even planning to look into this?
Comment 3 Michael K. Johnson 2003-08-08 16:49:33 EDT
Well, there's my usual "please try booting with acpi=off" but I doubt
it applies here.

We do not regularly test vmware installs that I'm aware of and we don't
list it as a supported platform, though we don't intentionally make it
non-functional either...  If the real hardware works (and I don't think
I've seen bug reports for pcnet32 on real hardware, and we know it is
rather a popular piece of hardware) it's hard to consider this a kernel

Note You need to log in before you can comment on or make changes to this bug.