Bug 1008770 - Can't leave fullscreen when using compiz
Can't leave fullscreen when using compiz
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: compiz (Show other bugs)
6.6
All Linux
medium Severity medium
: rc
: ---
Assigned To: Owen Taylor
Desktop QE
:
Depends On:
Blocks: 1002711
  Show dependency treegraph
 
Reported: 2013-09-17 00:16 EDT by John Newbigin
Modified: 2016-04-26 11:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-18 09:55:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Newbigin 2013-09-17 00:16:24 EDT
Description of problem:
Normally when using fullscreen in virt-manager, a little menu appears when the mouse is placed in the top centre of the screen.

When using compiz, the menu never pops up so you can not leave fullscreen mode.

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-18.el6.x86_64
compiz-0.8.2-24.el6.x86_64

How reproducible:
Every time. Turn off compiz (system -> preferences -> desktop effects) and it works. Turn on compiz and is stops working.

It does not matter if the vm is using spice or vnc.
Comment 2 Giuseppe Scrivano 2013-09-19 09:14:02 EDT
The bug seems to be caused by compiz that creates an invisible border to wrap the screen in order to detect some events.  Doing so, it inhibits virt-manager to receive events that happen on the border around the screen.

If my analysis is correct we can either:

1) fix the problem in compiz
2) workaround it in virt-manager to use a bigger button (I have tried to make the toolbar 3 pixels and it works) -- but the cost is also a bigger and uglier toolbar.

I personally would prefer to see a fix, or at least investigate it so I am reassigning the ticket to "compiz".

I have tried to reproduce the same problem with an upstream version of compiz (revno: 3789) and I couldn't hit the problem, this convinces me even more to give a try to fix it in compiz.

These are the steps I've followed, let me know if I've done something wrong.

$ bzr branch lp:compiz
$ mkdir compiz/build
$ cd compiz/build
$ cmake .. -DCMAKE_INSTALL_PREFIX=~/tmp
$ make -jN
$ make install
$ cd ~/tmp/
$ DISPLAY=:0 LD_LIBRARY_PATH=./lib ./bin/compiz --replace composite opengl

In addition, as a temporary fix, I can workaround the problem if I grab-ungrab the pointer when it is very close to the toolbar.

Please let me know if I can provide more information or assistance.
Comment 3 RHEL Product and Program Management 2013-10-13 19:10:08 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 5 Chris Williams 2015-09-18 09:55:45 EDT
This Bugzilla has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 6 and therefore will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification.

Note You need to log in before you can comment on or make changes to this bug.