This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1008795 - Netconsole service do not work when server is setted up as ipv6 address
Netconsole service do not work when server is setted up as ipv6 address
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Ryan Barry
Virtualization Bugs
:
Depends On:
Blocks: 1037955
  Show dependency treegraph
 
Reported: 2013-09-17 01:42 EDT by wanghui
Modified: 2014-01-21 14:50 EST (History)
15 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-4.el6
Doc Type: Bug Fix
Doc Text:
An IPv6 address could be entered for a netconsole server in the hypervisor, but netconsole does not support IPv6. IPv6 addresses entered are no longer valid.
Story Points: ---
Clone Of:
: 1037955 (view as bug list)
Environment:
Last Closed: 2014-01-21 14:50:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20124 None None None Never

  None (edit)
Description wanghui 2013-09-17 01:42:15 EDT
Description of problem:
When setted up the netconsole server as ipv6 address, it doesn't work.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130725.0.auto1831.el6.iso

How reproducible:
100%

Steps to Reproduce:
1. Clean install rhev-h 6.5.
2. Set Netconsole server address with ipv6 address.
3. Run # echo 7 >/proc/sys/kernel/printk
4. Test syslog service.

Actual results:
1. After step4, the netconsole service doesn't work.

Expected results:
1. After step4, the netconsole service should work.

Additional info:
1. No such issue in RSyslog.
2. No such issue when set netconsole address as ipv4 address or FQDN.
Comment 4 wanghui 2013-10-21 07:46:27 EDT
Test version:
rhev-hypervisor6-6.5-20131017.0.iso
ovirt-node-3.0.1-4.el6.noarch

Test steps:
1. Clean install rhev-h 6.5.
2. Set Netconsole server address with ipv6 address.


Test results:
1. After step2, it will give a prompt and not accept the ipv6 address.

According comment#2, the bug is fixed in rhev-hypervisor6-6.5-20131017.0.iso. So change the bug's status from ON_QA to VERIFIED.
Comment 7 Cheryn Tan 2013-11-07 19:36:21 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 9 errata-xmlrpc 2014-01-21 14:50:20 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.