Bug 1008857 - [ovirt-engine-notifier] RFE - notifier should keep sending mails when the problem is persistent
[ovirt-engine-notifier] RFE - notifier should keep sending mails when the pro...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-notification-service (Show other bugs)
3.3.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Yair Zaslavsky
Pavel Stehlik
infra
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 04:18 EDT by David Botzer
Modified: 2016-02-10 14:38 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-22 13:35:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Botzer 2013-09-17 04:18:09 EDT
Description of problem:
[ovirt-engine-notifier] RFE - notifier should keep sending mails when the problem is persistent

Version-Release number of selected component (if applicable):
3.3/is14

How reproducible:
always

Steps to Reproduce:
1.cofigure iptables to block connection between host & rhevm
2.verify host is non-responsive

Actual results:
Receives notification & error mails

Expected results:
notifier doesnt keep on sending error mails at the defined intervals

Additional info:
I would like to have repeated messages during this interval (INTERVAL_IN_SECONDS), meaning, if the
problem is persistent - e.x host is non-responsive - and delay is 1sec
I want notifier to keep sending mails every 1sec until the problem is fixed, or
until I change the parameters in notifier.log
Comment 1 Itamar Heim 2013-09-17 05:01:28 EDT
I'm not sure i agree. we send an "open" and "close" event. I don't want to flood someone's mailbox.
arthur?
Comment 2 Arthur Berezin 2013-09-22 13:17:23 EDT
Itamar, I'm with you on this one. 
We should email on event changes, not repeating messages that were already sent.
Comment 3 RHEL Product and Program Management 2013-09-22 13:35:20 EDT
Product Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.