Bug 1008889 - [RHSC] Stop volume when rebalance is in progress succeeds.
[RHSC] Stop volume when rebalance is in progress succeeds.
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
high Severity unspecified
: ---
: RHGS 2.1.2
Assigned To: Ramesh N
Shruti Sampat
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 05:48 EDT by Shruti Sampat
Modified: 2015-05-13 12:28 EDT (History)
8 users (show)

See Also:
Fixed In Version: CB3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:38:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine logs (830.02 KB, text/plain)
2013-09-17 06:06 EDT, Shruti Sampat
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19363 None None None Never

  None (edit)
Description Shruti Sampat 2013-09-17 05:48:40 EDT
Description of problem:
------------------------
After starting rebalance on a volume, trying to stop the volume, failed the first couple of times, but then eventually succeeded, while rebalance was still running.

Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.4.0-0.2.master.20130911113322.gite7ade4a.fc19 

How reproducible:
Observed it once.

Steps to Reproduce:
1. Start rebalance on a volume.
2. Try to start the volume while rebalance is still running. Try this a few times, it failed.
3. Left the setup as it is. The tasks subtab showed that rebalance was still running and the menu item for Rebalance -> Stop was enabled (which indicates that rebalance was still going on, according to engine DB).
4. Again try to stop the volume.

(Note: rebalance had actually completed, according to the gluster CLI output of rebalance status command, but the engine still showed it as running)

Actual results:
Stopping the volume succeeded, which should not be the case.

Expected results:
Stopping the volume should fail.

Additional info:
Comment 2 Shruti Sampat 2013-09-17 05:55:52 EDT
Step 2 in 'Steps to reproduce' should read as :

Try to stop the volume while rebalance is still running. Try this a few times, it failed.
Comment 3 Shruti Sampat 2013-09-17 06:06:39 EDT
Created attachment 798716 [details]
engine logs
Comment 4 Shruti Sampat 2013-10-18 09:01:03 EDT
Verified as fixed in Red Hat Storage Console Version: 2.1.2-0.0.scratch.beta1.el6_4. 

An error pop-up is shown on trying to stop a volume while rebalance is running on the volume.
Comment 5 Ramesh N 2014-01-03 03:46:33 EST
Doc Text is not required  as its a new feature and we already have an RFE
Comment 7 errata-xmlrpc 2014-02-25 02:38:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.