Bug 100892 - kickstart install tries incorectly to autopartition (?)
kickstart install tries incorectly to autopartition (?)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
FC2
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-26 16:42 EDT by Jay Berkenbilt
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 16:39:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The kickstart configuration file I tried to install with (1.17 KB, text/plain)
2003-07-26 16:43 EDT, Jay Berkenbilt
no flags Details
anaconda.log copied from /tmp (4.65 KB, text/plain)
2003-07-26 16:43 EDT, Jay Berkenbilt
no flags Details
screenshot of error screen (66.65 KB, image/png)
2003-07-26 16:44 EDT, Jay Berkenbilt
no flags Details
revised ks.cfg used for 0.94 (1.10 KB, text/plain)
2003-09-27 12:33 EDT, Jay Berkenbilt
no flags Details

  None (edit)
Description Jay Berkenbilt 2003-07-26 16:42:13 EDT
Description of problem:

I am attempting a kickstart install of SEVERN from a kickstart file I created by
 taking anaconda-ks.cfg from a previous SEVERN install and removing the lines
that don't apply to the other machines I want to install so that I get prompted
for those items.  This is a technique I have used successfully for RH9 and is
consistent with the kickstart documentation which suggests that when required
items are missing, they are supplied interactively.  I also have "interactive"
in the ks.cfg file.  I have no partition information in the ks.cfg file. 
Instead of prompting me to partition manually with Disk Druid, anaconda fails
saying it is unable to allocate a primary partition.  Details below.

Version-Release number of selected component (if applicable):

9.0.93

How reproducible:

always for me

Steps to Reproduce:
1. install graphically from CD with attached ks.cfg
2. press OK accepting defaults until this error appears
    
Actual results:

After hitting Next in the mouse configuration screen, an error dialog with the
title "Error Partitioning" pops up containing the text:

Could not allocate requested partitions:

Partitioning failed: Could not allocate partitions as primary partitions.

Press 'OK' to rebot your system.


Expected results:

I should have gotten the screen that lets me choose between automatic
partitioning and manual partitioning with disk druid as happened with RH9.

Additional info:

I am attaching my ks.cfg file, anaconda.log from the install, and a screenshot
of the error screen from anaconda.  Here is my partition table:

Disk /dev/hda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1             1       752   6040408+   b  Win95 FAT32
/dev/hda2   *       753       765    104422+  83  Linux
/dev/hda3           766      1275   4096575   83  Linux
/dev/hda4          1276      9729  67906755    5  Extended
/dev/hda5          1276      1785   4096543+  83  Linux
/dev/hda6          1786      4347  20579233+  83  Linux
/dev/hda7          4348      6909  20579233+  83  Linux
/dev/hda8          6910      9471  20579233+   b  Win95 FAT32
/dev/hda9          9472      9729   2072353+  82  Linux swap

/dev/hda1 has one of those other operating systems on it.  /dev/hda2 is /boot
which I was going to share between RH9 and SEVERN. /dev/hda3 is my RH9 root
partition which I was going to leave intact and mount as /rh9.  /dev/hda5 is a
blank ext3 partition which I was going to format and use a /.  The rest of the
partitions are data partitions (or swap) that I was going to leave alone.

I have used this technique for testing beta releases for years.

See attached files for remaining details.

As this will prevent me from using kickstart, which I was primarily going to do
to get all the packages I want since I can no longer select them (not a
complaint), I will instead proceed to install manually.  Hopefully this will be
fixed for beta2 which I will again attempt to install using kickstart.
Comment 1 Jay Berkenbilt 2003-07-26 16:43:15 EDT
Created attachment 93163 [details]
The kickstart configuration file I tried to install with
Comment 2 Jay Berkenbilt 2003-07-26 16:43:47 EDT
Created attachment 93164 [details]
anaconda.log copied from /tmp
Comment 3 Jay Berkenbilt 2003-07-26 16:44:42 EDT
Created attachment 93165 [details]
screenshot of error screen

I have included the text of this error message in my bug report. It is here for
completeness and reference.
Comment 4 Mike McLean 2003-07-28 12:55:08 EDT
Hmm, if I take one of my standard (network install) kickstarts and remove
partitioning information I don't see this bug.  Will try to reproduce more
literally.
Comment 5 Mike McLean 2003-08-13 16:30:55 EDT
I can replicate the problem if I use the exact kickstart file attached by the
reporter with an nfs kickstart of Severn-beta1.

I can also replicate the problem with the -re0813.nightly tree in the same way.
Comment 7 Mike McLean 2003-08-13 17:05:28 EDT
Ok, this problem seems to occur with kickstart installs that use the
'interactive' command, but do not use the 'clearpart' command.   My guess is
that the screen where you choose whether to use automatic or manual partitioning
is not properly hooked up for kickstart interactive installs.
Comment 8 Jeremy Katz 2003-08-13 20:10:32 EDT
Committed something that should fix this.  Could do with some testing, though.
Comment 9 Jay Berkenbilt 2003-08-15 12:47:55 EDT
Will this be in the second SEVERN?  If so, I'll test again by using the same
kickstart file.  (Actually, I'll diff the package lists and make any manual
edits I think are necessary.)
Comment 10 Jay Berkenbilt 2003-09-27 12:17:43 EDT
This isn't really fixed.  Instead of outright failing as it did before, it
instead still assumes autopartitioning and brings you to a screen to select
options.  This is the screen that has the choices "Remove all Linux partitions
on this system", "Remove all partitions on this system", and "Keep all
partitions and use existing free space".

Since my disk is already partitioned and has data on it, none of these options
are usable.

I'm going to try without "interactive" and report my results.
Comment 11 Jay Berkenbilt 2003-09-27 12:21:03 EDT
Without "interactive", I am brought to the "disk partitioning setup" screen.
Comment 12 Jay Berkenbilt 2003-09-27 12:33:50 EDT
Created attachment 94780 [details]
revised ks.cfg used for 0.94
Comment 13 Jay Berkenbilt 2003-09-27 12:35:56 EDT
Hmm.  There doesn't seem to be anything that I can do in Bugzilla to move this
back to "ASSIGNED" instead of "MODIFIED".  Hopefully someone will see these
changes.  I'm always a little worried about bugs that get stuck in MODIFIED
forever...
Comment 14 Jeremy Katz 2003-10-23 18:52:15 EDT
Bumping back to assigned, I didn't see these comments via mail and only came
back to look when mikem said something wasn't quite working right for him :/

Reverted that change for now, I'd rather go with the previously known and
understood behavior and fix this for FC2.
Comment 15 Jim Simmons 2004-03-10 10:50:44 EST
This also seems to affect Enterprise 3 (WS at least) Update 1. 
Without interactive you get asked whether you want to autopartition or
use Disk Druid to partition.  With it, it just assumes you want to
autopartition.
I've tested this with both NFS and http installs.
Comment 16 Rolando Lopez Lam 2005-06-09 21:54:52 EDT
I have the same problem with RHES v. 3 Upd 4 ... Is there any solution?
Comment 17 Jeremy Katz 2005-09-21 16:39:28 EDT
This should be better in the devel tree for FC5

Note You need to log in before you can comment on or make changes to this bug.