Bug 100901 - Source RPM does not rebuild- installed, but unpackaged files.
Source RPM does not rebuild- installed, but unpackaged files.
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: net-snmp (Show other bugs)
beta1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-26 18:10 EDT by Chris Kloiber
Modified: 2015-03-04 20:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-01 11:45:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Kloiber 2003-07-26 18:10:32 EDT
Description of problem:

Was trying to rebuild this package on Red Hat Enterprise Linux ES (v2.1)
originally (so I could later rebuild freeradius), and it stops mid-build and
asks a question interactively:

Writing Makefile for NetSNMP::agent
Checking if your kit is complete...
Looks good
Note (probably harmless): No library found for -lnetsnmp
Writing Makefile for SNMP
Unable to locate the MIBs, Please enter the path:  []

That much is not really a bug, as net-snmp is not packaged for RHEL ES (2.1)

But I figured if I rebuilt the package on Severn I might be able to deduce what
on earth it's looking for and try to provide it. The rebuild on Severn however
fails with this message:

RPM build errors:
error: Installed (but unpackaged) file(s) found:
   /usr/lib/perl5/5.8.1/i386-linux-thread-multi/perllocal.pod
    Installed (but unpackaged) file(s) found:
   /usr/lib/perl5/5.8.1/i386-linux-thread-multi/perllocal.pod

So I guess the spec file needs some 'love' in the %files section.

Version-Release number of selected component (if applicable):

net-snmp-5.0.8-4.src.rpm
Comment 1 Phil Knirsch 2003-07-31 10:45:13 EDT
I've just fixed another problem with net-snmp building when net-snmp-devel
wasn't installed. (net-snmp-5.0.8-6 and later).

Maybe this fixes this problem for you as well. Please verify. :-)

Read ya, Phil
Comment 2 Phil Knirsch 2003-08-01 11:45:34 EDT
OK, it's really fixed in dist-10 now, i had the same problem during rebuild and
figured where the problem was.

Fixed in the latest rawhide version.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.