Bug 1009016 - External scheduler doesn't load filters/weights/balancers
External scheduler doesn't load filters/weights/balancers
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-scheduler-proxy (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Martin Sivák
Pavel Stehlik
sla
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 09:49 EDT by Ondra Machacek
Modified: 2016-02-10 15:16 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 08:55:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ovirt-scheduler-proxy.log rpm from 27august (5.51 KB, text/plain)
2013-09-17 09:49 EDT, Ondra Machacek
no flags Details
diff is11 and upstream (12.90 KB, text/plain)
2013-09-17 09:51 EDT, Ondra Machacek
no flags Details

  None (edit)
Description Ondra Machacek 2013-09-17 09:49:55 EDT
Created attachment 798825 [details]
ovirt-scheduler-proxy.log rpm from 27august

Description of problem:
When external scheduler is setted up. Then engine doesn't get any information
about its plugins.

Version-Release number of selected component (if applicable):
is10-is15

How reproducible:
always

Steps to Reproduce:
1. yum install ovirt-scheduler-proxy
2. Create some filter/weight/balancer and add it to /usr/share/ovirt-scheduler-proxy/plugins/
3. rhevm-config -s ExternalSchedulerEnabled=true
4. service ovirt-scheduler-proxy start
5. service ovirt-engine restart
6. Check configure->clusterpolicy->new if you can use external plugins.

Actual results:
There are no external plugins.

Expected results:
It's possible to use external plugins.

Additional info:
Was working fine with rpm which was built on ~27th august from upstream.
But don't work with rpm from is10 - is15.

ovirt-scheduler-proxy.log from is10 rpm contains only:
Tue, 17 Sep 2013 15:32:13 INFO     Setting up server
Tue, 17 Sep 2013 15:32:13 INFO     Loading modules
Tue, 17 Sep 2013 15:32:13 INFO     Loading modules

ovirt-scheduler-proxy.log from rpm built on 27aug are attached.

Attaching also diff from is11 rpm and rpm which is working from 27aug.
Comment 1 Ondra Machacek 2013-09-17 09:51:32 EDT
Created attachment 798826 [details]
diff is11 and upstream
Comment 2 Martin Sivák 2013-09-17 10:59:46 EDT
The plugin API changed twice - first on the 15th of Aug and then again on the 3rd of Sep. Please make sure your test plugins are indeed valid for the release you are testing.

You can find the current example plugins in /usr/share/doc/ovirt-sheduler-proxy*/ directory.
Comment 3 Lukas Svaty 2013-09-24 09:31:07 EDT
Tried external balancer with examples in /usr/share/doc/ovirt-sheduler-proxy*/ directory (vm_balance.py) and balancer was loaded successfully. 

Had the same behaviour when I used old API.

Tested on is16.
Comment 4 Ondra Machacek 2013-10-02 08:55:41 EDT
I tested balancer/weights/filters with old API.

Balancers/weights/filters from current documentation works OK, thus closing as
 not a bug

Note You need to log in before you can comment on or make changes to this bug.