This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1009028 - Business central in cluster cannot be redeployed
Business central in cluster cannot be redeployed
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ER4
: 6.0.0
Assigned To: Maciej Swiderski
Radovan Synek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 10:16 EDT by Radovan Synek
Modified: 2014-08-06 16:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:10:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
node one server log (267.22 KB, text/x-log)
2013-09-17 10:16 EDT, Radovan Synek
no flags Details
node two server log (319.42 KB, text/x-log)
2013-09-17 10:16 EDT, Radovan Synek
no flags Details

  None (edit)
Description Radovan Synek 2013-09-17 10:16:18 EDT
Created attachment 798836 [details]
node one server log

Attempt for redeploy of business central in cluster ended up with "Operation failed or was rolled back on all servers". Server logs contain exceptions with root cause:
org.apache.helix.HelixException: instance nodeOne_12345 already has a liveinstance in cluster jbpm-cluster

Version-Release number of selected component (if applicable):
BPMS-6.0.0.ER3

Steps to Reproduce:
1. configure cluster with 2 nodes
2. deploy business central
3. undeploy business central
4. deploy business central again => operation failed, see server logs

Attaching server logs from both nodes - containing useful information
Comment 1 Radovan Synek 2013-09-17 10:16:54 EDT
Created attachment 798837 [details]
node two server log
Comment 2 Radovan Synek 2013-09-17 10:24:19 EDT
To make it clear - there is a workaround - to stop & destroy the cluster completely, create it again and deploy business central once more. But this can be hardly final solution.
Comment 4 Radovan Synek 2013-10-17 09:47:27 EDT
Verified on BPMS-6.0.0.ER4

Note You need to log in before you can comment on or make changes to this bug.