Bug 1009030 - No way to import files
No way to import files
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: ER2
: 6.0.1
Assigned To: Toni Rikkola
Tomas Livora
:
: 1069699 (view as bug list)
Depends On: 1005707
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 10:17 EDT by Zuzana Krejčová
Modified: 2014-08-06 15:58 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 15:58:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zuzana Krejčová 2013-09-17 10:17:27 EDT
Description of problem:

There is no way to import ordinary files. This feature was present in the 5.3.x branch, now it is missing.

E.g. if you want to upload some .gif icons for your service tasks/work item definitions, you cannot do that through the business-central. 
You'd have to add it to the underlying git repository (and restart the server with how things are now). If you even had access to that.
Comment 1 Jiri Locker 2013-09-18 03:37:16 EDT
Related issue.
Comment 5 Toni Rikkola 2013-11-18 08:48:10 EST
Fixing bug 1005707 will also fix this.
Comment 6 Edson Tirelli 2013-11-18 14:56:16 EST
Toni, I am raising the priority of this so that we get it done for the product release.
Comment 7 Zuzana Krejčová 2013-12-20 10:57:32 EST
There's a new item in 'New Item' menu, called Uploaded file. Choosing that, you get a 'Create New ..' dialog, you can set the resource name and choose a file... and that's it. Clicking Ok makes the dialog disappear but nothing else happens. File isn't uploaded. Nothing new in git.
Comment 9 Lukáš Petrovický 2014-02-07 11:19:38 EST
This no longer has a target release of 6.0.0.
Comment 10 Zuzana Krejčová 2014-02-21 05:38:57 EST
Still the same behaviour as described in comment 7.
Comment 11 Toni Rikkola 2014-02-25 05:48:43 EST
Ok, we are overwriting the web.xml files that I tested with when we use wars. So here should finally be the fixes for tomcat, jboss as, eap and websphere.

master: https://github.com/droolsjbpm/kie-wb-distributions/commit/1adae09bd
6.0.x: https://github.com/droolsjbpm/kie-wb-distributions/commit/06e787129
Comment 12 Toni Rikkola 2014-02-26 05:25:44 EST
*** Bug 1069699 has been marked as a duplicate of this bug. ***
Comment 13 Tomas Livora 2014-03-12 11:54:20 EDT
Verified on BRMS 6.0.1 ER2

Note You need to log in before you can comment on or make changes to this bug.