Bug 1009040 - Resizing non-primary monitor results in wallpaper that is size of primary VM.
Resizing non-primary monitor results in wallpaper that is size of primary VM.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: spice-qxl-driver-win (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Alon Levy
Desktop QE
: Reopened
Depends On:
Blocks: 1009648
  Show dependency treegraph
 
Reported: 2013-09-17 10:25 EDT by Bill Sanford
Modified: 2014-06-09 09:06 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-09 09:06:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the non-primary display resize (1.82 MB, image/png)
2013-09-17 10:25 EDT, Bill Sanford
no flags Details
Screenshot of the primary display resize (2.03 MB, image/png)
2013-09-17 10:26 EDT, Bill Sanford
no flags Details

  None (edit)
Description Bill Sanford 2013-09-17 10:25:59 EDT
Created attachment 798839 [details]
Screenshot of the non-primary display resize

Description of problem:
If the primary display is smaller than the secondary display and you resize the secondary display, the wallpaper on the secondary display is resized to the display size of the primary display. However, when I then resize the primary display, the secondary display resizes the wallpaper to the normal resolution of the display.

Version-Release number of selected component (if applicable):
rhev-guest-tools-iso-3.3-5.noarch.rpm
RHEL6.5-20130912.n.2
rhev-hypervisor6-6.5-20130910.2.el6ev.noarch.rpm
Windows XP VM

How reproducible:
100%


Steps to Reproduce:
1.
2.
3.

Actual results:
Resize the secondary display to something larger than the primary resolution and the display wallpaper is the size of the primary display.

Expected results:
Resize the secondary display to something larger than the primary resolution and the display wallpaper should match the display.

Additional info:

First terminal
/usr/libexec/qemu-kvm -m 2048 -spice port=3001,disable-ticketing,addr=127.0.0.1,seamless-migration=on -vga qxl -device qxl -global qxl-vga.vram_size=67108864 -device virtio-serial -chardev spicevmc,id=vdagent,name=vdagent -device virtserialport,chardev=vdagent,name=com.redhat.spice.0 -chardev spicevmc,name=usbredir,id=usbredirchardev1 -device usb-redir,chardev=usbredirchardev1,id=usbredirdev1,debug=3,filter='0x08:-1:-1:-1:1|-1:-1:-1:-1:0' -readconfig /etc/qemu/ich9-ehci-uhci.cfg /home/images/WinXP.img -monitor stdio 

Second terminal
/usr/libexec/qemu-kvm -m 2048 -spice port=3002,disable-ticketing,addr=127.0.0.1,seamless-migration=on -vga qxl -device qxl -global qxl-vga.vram_size=67108864 -device virtio-serial -chardev spicevmc,id=vdagent,name=vdagent -device virtserialport,chardev=vdagent,name=com.redhat.spice.0 -chardev spicevmc,name=usbredir,id=usbredirchardev1 -device usb-redir,chardev=usbredirchardev1,id=usbredirdev1,debug=3,filter='0x08:-1:-1:-1:1|-1:-1:-1:-1:0' -readconfig /etc/qemu/ich9-ehci-uhci.cfg /home/images/WinXP.img -monitor stdio -incoming tcp:127.0.0.1:4444 

Third terminal 
remote-viewer spice://127.0.0.1?port=3001
Comment 1 Bill Sanford 2013-09-17 10:26:50 EDT
Created attachment 798841 [details]
Screenshot of the primary display resize
Comment 2 Christophe Fergeau 2013-09-17 10:33:01 EDT
Isn't this a duplicate of rhbz#958153 ?
Comment 3 David Jaša 2013-09-17 10:43:43 EDT
It is, and it is a standard windows behaviour as well that can be observed on machines that have never seen qxl device.
Comment 6 Bill Sanford 2013-09-17 11:55:01 EDT
This is not a duplicate.
Comment 7 Marc-Andre Lureau 2013-09-17 11:57:31 EDT
fwiw I opt for duplicate too.
Comment 13 Bill Sanford 2013-09-23 11:43:11 EDT
This is the same with a Windows 7x86 VM.
Comment 15 Alon Levy 2014-05-25 17:53:33 EDT
Bill - I checked win7 on a physical machine (not qxl) and saw the same behavior, i.e. secondary wallpaper doesn't take all the monitor if resolution is larger then primary. Any reason not to close this?
Comment 16 Bill Sanford 2014-06-09 09:06:51 EDT
I think we can close this as a Windows issue.

Note You need to log in before you can comment on or make changes to this bug.