Bug 1009064 - [abrt] firefox-17.0.8-1.el6_4 : xcb_glx_query_server_string_string_length : Firefox crashes after tigervnc-server-module is loaded in Xorg
[abrt] firefox-17.0.8-1.el6_4 : xcb_glx_query_server_string_string_length : F...
Status: CLOSED DUPLICATE of bug 1016032
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: firefox (Show other bugs)
6.4
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Red Hat Gecko Maintainer
Desktop QE
:
Depends On:
Blocks: 1016032
  Show dependency treegraph
 
Reported: 2013-09-17 11:06 EDT by Deepu K S
Modified: 2013-10-08 12:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1016032 (view as bug list)
Environment:
Last Closed: 2013-10-08 12:12:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full Thread Backtrace (10.15 KB, text/plain)
2013-09-17 11:06 EDT, Deepu K S
no flags Details
Xorg logs (35.49 KB, text/plain)
2013-09-17 11:09 EDT, Deepu K S
no flags Details

  None (edit)
Description Deepu K S 2013-09-17 11:06:46 EDT
Created attachment 798858 [details]
Full Thread Backtrace

Description of problem:
/usr/lib64/firefox/firefox was killed by segfault in libxcb-glx.so.0.0.0

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux 6.4
firefox-17.0.8-1.el6_4.x86_64
tigervnc-server-module-1.1.0-5.el6_4.1.x86_64
libxcb-1.8.1-1.el6.x86_64

How reproducible:
Crash happens every time libvnc.so module is loaded in Xorg.

Steps to Reproduce:
1. Install tigervnc-server-module-1.1.0-5.el6_4.1.x86_64 package.
2. Create xorg.conf in /etc/X11/ with loading vnc extension. Below is the contents of xorg.conf file.

Section "Module"
Load "vnc"
EndSection

Section "Screen"
Identifier "Screen 1"
Option "SecurityTypes" "None"
EndSection

3. Logout from session and re-login/ Restart X
4. After Logging in, start firefox. X session crash happens and coming back to login screen.
5. If vnc module is not loaded, everything works as normal.

Actual results:
Firefox gets killed by segfault. And crashes the Xorg session. Crash happening in libxcb-glx.so.0.0.0

Expected results:
Firefox should start as normal. Xorg session should not crash.

Additional info:

The crash is happening at libxcb-1.8.1/src/glx.c +2444 in xcb_glx_query_server_string_string_length. The value passed is 0x0 for getting the string length.
Attached is the backtrace, Xorg.0.log, /var/log/messages .
Comment 1 Deepu K S 2013-09-17 11:09:14 EDT
Created attachment 798859 [details]
Xorg logs
Comment 4 Martin Stransky 2013-10-08 12:12:50 EDT

*** This bug has been marked as a duplicate of bug 1016032 ***

Note You need to log in before you can comment on or make changes to this bug.