Bug 1009073 - BPMN: Missing attribute x in lane
BPMN: Missing attribute x in lane
Status: CLOSED DUPLICATE of bug 958400
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity high
: ER5
: 6.0.0
Assigned To: Kris Verlaenen
Tomas Livora
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 11:18 EDT by Pedro Zapata
Modified: 2014-01-28 18:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-28 18:12:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Exported BPMN process (71.61 KB, application/xml)
2013-09-17 11:18 EDT, Pedro Zapata
no flags Details

  None (edit)
Description Pedro Zapata 2013-09-17 11:18:23 EDT
Created attachment 798862 [details]
Exported BPMN process

The lane description has apparently be corrupted while designing process, the attribute x is missing from the XML.

     <bpmndi:BPMNShape id="_VHPGwB-nEeOpSfcbFdHwOg" bpmnElement="_DEF58EB7-C04A-4CDA-B855-B41ECF30B3DA">
        <dc:Bounds height="215.0" width="1740.0"
 y="30.0"/>
      </bpmndi:BPMNShape>

This causes a process validation error and exception which is not possible to recover from:

16:54:51,649 ERROR [org.drools.core.xml.ExtensibleXmlParser] (http-localhost/127.0.0.1:8080-2) (null: 602, 61): cvc-complex-type.4: Attribute 'x' must appear on element 'dc:Bounds'.
16:54:51,650 ERROR [stderr] (http-localhost/127.0.0.1:8080-2) java.lang.IllegalArgumentException: Invalid bounds for node _77B2F150-58FC-464B-B3BE-B5B206DACEF2
16:54:51,650 ERROR [stderr] (http-localhost/127.0.0.1:8080-2)   at org.jbpm.bpmn2.xml.di.BPMNShapeHandler.end(BPMNShapeHandler.java:84)
16:54:51,650 ERROR [stderr] (http-localhost/127.0.0.1:8080-2)   at org.drools.core.xml.ExtensibleXmlParser.endElement(ExtensibleXmlParser.java:422)
16:54:51,650 ERROR [stderr] (http-localhost/127.0.0.1:8080-2)   at org.apache.xerces.parsers.AbstractSAXParser.endElement(Unknown Source)
16:54:51,651 ERROR [stderr] (http-localhost/127.0.0.1:8080-2)   at org.apache.xerces.impl.xs.XMLSchemaValidator.endElement(Unknown Source)

Exported BPMN process
Comment 2 Kris Verlaenen 2013-10-10 10:59:54 EDT
Making sure parser doesn't choke on missing UI information

master: http://github.com/droolsjbpm/jbpm/commit/d009e31a2
6.0.x: http://github.com/droolsjbpm/jbpm/commit/9a99cfbcc

Still need to verify I can now successfully open the attached process when this fix is included in a recent build of the tooling
Comment 3 Tomas Livora 2013-11-27 05:34:49 EST
The bug is not fixed in ER5. When you place a new Lane to the left border of the designer, X-coordinate should be 0 but it is not defined. Validating output is:

ERROR [org.drools.core.xml.ExtensibleXmlParser] (http-localhost/127.0.0.1:8080-1) (null: 49, 60): cvc-complex-type.4: Attribute 'x' must appear on element 'dc:Bounds'.

The same problem is with Y-coordinate when you place the Lane to the top border.
Comment 4 Kris Verlaenen 2013-11-27 10:17:27 EST
@Tomas, is this preventing the process from being imported, or from being validated, or from being built and deployed?  Or is this simply a warning in the server log?
Comment 5 Kris Verlaenen 2013-11-28 17:15:50 EST
Lowering priority as this now seems to be just an error message in the server log, it doesn't seem to break any functionality.
Comment 6 Tomas Livora 2013-11-29 05:02:42 EST
@Kris, the process containing a Lane with undefined X or Y coordinate is now validated without errors and can be built and deployed. However, there is still the error message in the server log. But you are right, this is not a big issue so I am lowering severity.
Comment 7 Kris Verlaenen 2014-01-28 18:12:19 EST
No need to have two BZs keeping track of this

*** This bug has been marked as a duplicate of bug 958400 ***

Note You need to log in before you can comment on or make changes to this bug.