Bug 1009101 - yum skips packages that shouldn't skip with skip-broken
yum skips packages that shouldn't skip with skip-broken
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 13:04 EDT by nucleo
Modified: 2016-07-19 06:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 06:24:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nucleo 2013-09-17 13:04:38 EDT
Description of problem:
yum skips packages that shouldn't skip with skip-broken.

Version-Release number of selected component (if applicable):
yum-3.4.3-110.fc21.noarch

How reproducible:
Sometimes.

Steps to Reproduce:
1. Run yum with --skip-broken, if there are problems with broken deps
2.
3.

Actual results:
yum skips packages that shouldn't skip.

Expected results:
Only packages with broken deps should be skipped.

Additional info:
There are broken deps in Rawhide:

# yum update
Loaded plugins: refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package ImageMagick.i686 0:6.8.6.3-3.fc20 will be updated
---> Package ImageMagick.i686 0:6.8.6.3-4.fc21 will be an update
---> Package ImageMagick-libs.i686 0:6.8.6.3-3.fc20 will be updated
---> Package ImageMagick-libs.i686 0:6.8.6.3-4.fc21 will be an update
---> Package OpenEXR-libs.i686 0:1.7.1-6.fc20 will be updated
--> Processing Dependency: libIlmImf.so.7 for package: vigra-1.9.0-11.fc21.i686
--> Processing Dependency: libIlmImf.so.7 for package: enblend-4.1.1-5.fc20.i686
---> Package OpenEXR-libs.i686 0:2.0.1-1.fc21 will be an update
---> Package ghostscript.i686 0:9.09-1.fc21 will be updated
---> Package ghostscript.i686 0:9.10-1.fc21 will be an update
---> Package heisenbug-kde-theme.noarch 0:19.90.2-1.fc21 will be updated
---> Package heisenbug-kde-theme.noarch 0:19.90.3-1.fc21 will be an update
---> Package hugin-base.i686 0:2012.0.0-10.fc21 will be updated
---> Package hugin-base.i686 0:2012.0.0-11.fc21 will be an update
---> Package ilmbase.i686 0:1.0.3-7.fc21 will be updated
--> Processing Dependency: libHalf.so.6 for package: vigra-1.9.0-11.fc21.i686
--> Processing Dependency: libHalf.so.6 for package: enblend-4.1.1-5.fc20.i686
--> Processing Dependency: libIex.so.6 for package: vigra-1.9.0-11.fc21.i686
--> Processing Dependency: libIex.so.6 for package: enblend-4.1.1-5.fc20.i686
--> Processing Dependency: libIexMath.so.6 for package: enblend-4.1.1-5.fc20.i686
--> Processing Dependency: libIlmThread.so.6 for package: vigra-1.9.0-11.fc21.i686
--> Processing Dependency: libIlmThread.so.6 for package: enblend-4.1.1-5.fc20.i686
--> Processing Dependency: libImath.so.6 for package: vigra-1.9.0-11.fc21.i686
--> Processing Dependency: libImath.so.6 for package: enblend-4.1.1-5.fc20.i686
---> Package ilmbase.i686 0:2.0.1-1.fc21 will be an update
---> Package kcm_colors.i686 0:4.11.1-1.fc21 will be updated
---> Package kcm_colors.i686 0:4.11.1-2.fc21 will be an update
---> Package kde-runtime.i686 0:4.11.1-1.fc21 will be updated
---> Package kde-runtime.i686 0:4.11.1-2.fc21 will be an update
---> Package kde-runtime-drkonqi.i686 0:4.11.1-1.fc21 will be updated
---> Package kde-runtime-drkonqi.i686 0:4.11.1-2.fc21 will be an update
---> Package kde-runtime-flags.noarch 0:4.11.1-1.fc21 will be updated
---> Package kde-runtime-flags.noarch 0:4.11.1-2.fc21 will be an update
---> Package kde-runtime-libs.i686 0:4.11.1-1.fc21 will be updated
---> Package kde-runtime-libs.i686 0:4.11.1-2.fc21 will be an update
---> Package kde-workspace.i686 0:4.11.1-1.fc21 will be updated
---> Package kde-workspace.i686 0:4.11.1-2.fc21 will be an update
---> Package kde-workspace-ksplash-themes.noarch 0:4.11.1-1.fc21 will be updated
---> Package kde-workspace-ksplash-themes.noarch 0:4.11.1-2.fc21 will be an update
---> Package kde-workspace-libs.i686 0:4.11.1-1.fc21 will be updated
---> Package kde-workspace-libs.i686 0:4.11.1-2.fc21 will be an update
---> Package kdelibs.i686 6:4.11.1-2.fc21 will be updated
---> Package kdelibs.i686 6:4.11.1-3.fc21 will be an update
---> Package kdelibs-common.i686 6:4.11.1-2.fc21 will be updated
---> Package kdelibs-common.i686 6:4.11.1-3.fc21 will be an update
---> Package kdeplasma-addons.i686 0:4.11.1-1.fc21 will be updated
---> Package kdeplasma-addons.i686 0:4.11.1-2.fc21 will be an update
---> Package kdeplasma-addons-libs.i686 0:4.11.1-1.fc21 will be updated
---> Package kdeplasma-addons-libs.i686 0:4.11.1-2.fc21 will be an update
---> Package kdesdk-strigi-analyzers.i686 0:4.11.1-1.fc21 will be updated
---> Package kdesdk-strigi-analyzers.i686 0:4.11.1-2.fc21 will be an update
---> Package kdm.i686 0:4.11.1-1.fc21 will be updated
---> Package kdm.i686 0:4.11.1-2.fc21 will be an update
---> Package kgreeter-plugins.i686 0:4.11.1-1.fc21 will be updated
---> Package kgreeter-plugins.i686 0:4.11.1-2.fc21 will be an update
---> Package ksysguard.i686 0:4.11.1-1.fc21 will be updated
---> Package ksysguard.i686 0:4.11.1-2.fc21 will be an update
---> Package ksysguard-libs.i686 0:4.11.1-1.fc21 will be updated
---> Package ksysguard-libs.i686 0:4.11.1-2.fc21 will be an update
---> Package ksysguardd.i686 0:4.11.1-1.fc21 will be updated
---> Package ksysguardd.i686 0:4.11.1-2.fc21 will be an update
---> Package kwin-gles-libs.i686 0:4.11.1-1.fc21 will be updated
---> Package kwin-gles-libs.i686 0:4.11.1-2.fc21 will be an update
---> Package libkworkspace.i686 0:4.11.1-1.fc21 will be updated
---> Package libkworkspace.i686 0:4.11.1-2.fc21 will be an update
---> Package lm_sensors-libs.i686 0:3.3.4-7.fc20 will be updated
---> Package lm_sensors-libs.i686 0:3.3.4-8.fc21 will be an update
---> Package opencv.i686 0:2.4.6.1-1.fc20 will be updated
---> Package opencv.i686 0:2.4.6.1-2.fc21 will be an update
---> Package opencv-core.i686 0:2.4.6.1-1.fc20 will be updated
---> Package opencv-core.i686 0:2.4.6.1-2.fc21 will be an update
---> Package perl-Encode.i686 1:2.54-1.fc21 will be updated
---> Package perl-Encode.i686 1:2.55-1.fc21 will be an update
---> Package qtwebkit.i686 0:2.3.2-2.fc20 will be updated
---> Package qtwebkit.i686 0:2.3.2-3.fc21 will be an update
---> Package xorg-x11-server-utils.i686 0:7.7-2.fc20 will be updated
---> Package xorg-x11-server-utils.i686 0:7.7-4.fc21 will be an update
---> Package xulrunner.i686 0:23.0.1-4.fc21 will be updated
--> Processing Dependency: libxul.so(xul23.0.1) for package: firefox-23.0.1-5.fc21.i686
---> Package xulrunner.i686 0:24.0-2.fc21 will be an update
--> Processing Conflict: firefox-23.0.1-5.fc21.i686 conflicts xulrunner(x86-32) > 23.1
--> Finished Dependency Resolution
Error: Package: vigra-1.9.0-11.fc21.i686 (@rawhide)
           Requires: libHalf.so.6
           Removing: ilmbase-1.0.3-7.fc21.i686 (@rawhide)
               libHalf.so.6
           Updated By: ilmbase-2.0.1-1.fc21.i686 (rawhide)
              ~libHalf.so.10
Error: Package: enblend-4.1.1-5.fc20.i686 (@rawhide)
           Requires: libIlmThread.so.6
           Removing: ilmbase-1.0.3-7.fc21.i686 (@rawhide)
               libIlmThread.so.6
           Updated By: ilmbase-2.0.1-1.fc21.i686 (rawhide)
               Not found
Error: Package: vigra-1.9.0-11.fc21.i686 (@rawhide)
           Requires: libIlmThread.so.6
           Removing: ilmbase-1.0.3-7.fc21.i686 (@rawhide)
               libIlmThread.so.6
           Updated By: ilmbase-2.0.1-1.fc21.i686 (rawhide)
               Not found
Error: Package: enblend-4.1.1-5.fc20.i686 (@rawhide)
           Requires: libIex.so.6
           Removing: ilmbase-1.0.3-7.fc21.i686 (@rawhide)
               libIex.so.6
           Updated By: ilmbase-2.0.1-1.fc21.i686 (rawhide)
               Not found
Error: Package: enblend-4.1.1-5.fc20.i686 (@rawhide)
           Requires: libIlmImf.so.7
           Removing: OpenEXR-libs-1.7.1-6.fc20.i686 (@rawhide)
               libIlmImf.so.7
           Updated By: OpenEXR-libs-2.0.1-1.fc21.i686 (rawhide)
               Not found
Error: Package: enblend-4.1.1-5.fc20.i686 (@rawhide)
           Requires: libIexMath.so.6
           Removing: ilmbase-1.0.3-7.fc21.i686 (@rawhide)
               libIexMath.so.6
           Updated By: ilmbase-2.0.1-1.fc21.i686 (rawhide)
               Not found
Error: Package: vigra-1.9.0-11.fc21.i686 (@rawhide)
           Requires: libIex.so.6
           Removing: ilmbase-1.0.3-7.fc21.i686 (@rawhide)
               libIex.so.6
           Updated By: ilmbase-2.0.1-1.fc21.i686 (rawhide)
               Not found
Error: Package: firefox-23.0.1-5.fc21.i686 (@rawhide)
           Requires: libxul.so(xul23.0.1)
           Removing: xulrunner-23.0.1-4.fc21.i686 (@rawhide)
               libxul.so(xul23.0.1)
           Updated By: xulrunner-24.0-2.fc21.i686 (rawhide)
               Not found
Error: Package: enblend-4.1.1-5.fc20.i686 (@rawhide)
           Requires: libImath.so.6
           Removing: ilmbase-1.0.3-7.fc21.i686 (@rawhide)
               libImath.so.6
           Updated By: ilmbase-2.0.1-1.fc21.i686 (rawhide)
               Not found
Error: Package: vigra-1.9.0-11.fc21.i686 (@rawhide)
           Requires: libImath.so.6
           Removing: ilmbase-1.0.3-7.fc21.i686 (@rawhide)
               libImath.so.6
           Updated By: ilmbase-2.0.1-1.fc21.i686 (rawhide)
               Not found
Error: firefox conflicts with xulrunner-24.0-2.fc21.i686
Error: Package: vigra-1.9.0-11.fc21.i686 (@rawhide)
           Requires: libIlmImf.so.7
           Removing: OpenEXR-libs-1.7.1-6.fc20.i686 (@rawhide)
               libIlmImf.so.7
           Updated By: OpenEXR-libs-2.0.1-1.fc21.i686 (rawhide)
               Not found
Error: Package: enblend-4.1.1-5.fc20.i686 (@rawhide)
           Requires: libHalf.so.6
           Removing: ilmbase-1.0.3-7.fc21.i686 (@rawhide)
               libHalf.so.6
           Updated By: ilmbase-2.0.1-1.fc21.i686 (rawhide)
              ~libHalf.so.10
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest




So, I run yum with --skip-broken


# LANG=C yum update --skip-broken
Loaded plugins: refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package ImageMagick.i686 0:6.8.6.3-3.fc20 will be updated
---> Package ImageMagick.i686 0:6.8.6.3-4.fc21 will be an update
---> Package ImageMagick-libs.i686 0:6.8.6.3-3.fc20 will be updated
---> Package ImageMagick-libs.i686 0:6.8.6.3-4.fc21 will be an update
---> Package OpenEXR-libs.i686 0:1.7.1-6.fc20 will be updated
--> Processing Dependency: libIlmImf.so.7 for package: vigra-1.9.0-11.fc21.i686
--> Processing Dependency: libIlmImf.so.7 for package: enblend-4.1.1-5.fc20.i686
---> Package OpenEXR-libs.i686 0:2.0.1-1.fc21 will be an update
---> Package ghostscript.i686 0:9.09-1.fc21 will be updated
---> Package ghostscript.i686 0:9.10-1.fc21 will be an update
---> Package hugin-base.i686 0:2012.0.0-10.fc21 will be updated
---> Package hugin-base.i686 0:2012.0.0-11.fc21 will be an update
---> Package ilmbase.i686 0:1.0.3-7.fc21 will be updated
--> Processing Dependency: libHalf.so.6 for package: vigra-1.9.0-11.fc21.i686
--> Processing Dependency: libHalf.so.6 for package: enblend-4.1.1-5.fc20.i686
--> Processing Dependency: libIex.so.6 for package: vigra-1.9.0-11.fc21.i686
--> Processing Dependency: libIex.so.6 for package: enblend-4.1.1-5.fc20.i686
--> Processing Dependency: libIexMath.so.6 for package: enblend-4.1.1-5.fc20.i686
--> Processing Dependency: libIlmThread.so.6 for package: vigra-1.9.0-11.fc21.i686
--> Processing Dependency: libIlmThread.so.6 for package: enblend-4.1.1-5.fc20.i686
--> Processing Dependency: libImath.so.6 for package: vigra-1.9.0-11.fc21.i686
--> Processing Dependency: libImath.so.6 for package: enblend-4.1.1-5.fc20.i686
---> Package ilmbase.i686 0:2.0.1-1.fc21 will be an update
---> Package kcm_colors.i686 0:4.11.1-1.fc21 will be updated
---> Package kcm_colors.i686 0:4.11.1-2.fc21 will be an update
---> Package kde-runtime.i686 0:4.11.1-1.fc21 will be updated
---> Package kde-runtime.i686 0:4.11.1-2.fc21 will be an update
---> Package kde-runtime-drkonqi.i686 0:4.11.1-1.fc21 will be updated
---> Package kde-runtime-drkonqi.i686 0:4.11.1-2.fc21 will be an update
---> Package kde-runtime-flags.noarch 0:4.11.1-1.fc21 will be updated
---> Package kde-runtime-flags.noarch 0:4.11.1-2.fc21 will be an update
---> Package kde-runtime-libs.i686 0:4.11.1-1.fc21 will be updated
---> Package kde-runtime-libs.i686 0:4.11.1-2.fc21 will be an update
---> Package kde-workspace.i686 0:4.11.1-1.fc21 will be updated
---> Package kde-workspace.i686 0:4.11.1-2.fc21 will be an update
---> Package kde-workspace-ksplash-themes.noarch 0:4.11.1-1.fc21 will be updated
---> Package kde-workspace-ksplash-themes.noarch 0:4.11.1-2.fc21 will be an update
---> Package kde-workspace-libs.i686 0:4.11.1-1.fc21 will be updated
---> Package kde-workspace-libs.i686 0:4.11.1-2.fc21 will be an update
---> Package kdelibs.i686 6:4.11.1-2.fc21 will be updated
---> Package kdelibs.i686 6:4.11.1-3.fc21 will be an update
---> Package kdelibs-common.i686 6:4.11.1-2.fc21 will be updated
---> Package kdelibs-common.i686 6:4.11.1-3.fc21 will be an update
---> Package kdeplasma-addons.i686 0:4.11.1-1.fc21 will be updated
---> Package kdeplasma-addons.i686 0:4.11.1-2.fc21 will be an update
---> Package kdeplasma-addons-libs.i686 0:4.11.1-1.fc21 will be updated
---> Package kdeplasma-addons-libs.i686 0:4.11.1-2.fc21 will be an update
---> Package kdesdk-strigi-analyzers.i686 0:4.11.1-1.fc21 will be updated
---> Package kdesdk-strigi-analyzers.i686 0:4.11.1-2.fc21 will be an update
---> Package kdm.i686 0:4.11.1-1.fc21 will be updated
---> Package kdm.i686 0:4.11.1-2.fc21 will be an update
---> Package kgreeter-plugins.i686 0:4.11.1-1.fc21 will be updated
---> Package kgreeter-plugins.i686 0:4.11.1-2.fc21 will be an update
---> Package ksysguard.i686 0:4.11.1-1.fc21 will be updated
---> Package ksysguard.i686 0:4.11.1-2.fc21 will be an update
---> Package ksysguard-libs.i686 0:4.11.1-1.fc21 will be updated
---> Package ksysguard-libs.i686 0:4.11.1-2.fc21 will be an update
---> Package ksysguardd.i686 0:4.11.1-1.fc21 will be updated
---> Package ksysguardd.i686 0:4.11.1-2.fc21 will be an update
---> Package kwin-gles-libs.i686 0:4.11.1-1.fc21 will be updated
---> Package kwin-gles-libs.i686 0:4.11.1-2.fc21 will be an update
---> Package libkworkspace.i686 0:4.11.1-1.fc21 will be updated
---> Package libkworkspace.i686 0:4.11.1-2.fc21 will be an update
---> Package lm_sensors-libs.i686 0:3.3.4-7.fc20 will be updated
---> Package lm_sensors-libs.i686 0:3.3.4-8.fc21 will be an update
---> Package opencv.i686 0:2.4.6.1-1.fc20 will be updated
---> Package opencv.i686 0:2.4.6.1-2.fc21 will be an update
---> Package opencv-core.i686 0:2.4.6.1-1.fc20 will be updated
---> Package opencv-core.i686 0:2.4.6.1-2.fc21 will be an update
---> Package perl-Encode.i686 1:2.54-1.fc21 will be updated
---> Package perl-Encode.i686 1:2.55-1.fc21 will be an update
---> Package qtwebkit.i686 0:2.3.2-2.fc20 will be updated
---> Package qtwebkit.i686 0:2.3.2-3.fc21 will be an update
---> Package xorg-x11-server-utils.i686 0:7.7-2.fc20 will be updated
---> Package xorg-x11-server-utils.i686 0:7.7-4.fc21 will be an update
---> Package xulrunner.i686 0:23.0.1-4.fc21 will be updated
--> Processing Dependency: libxul.so(xul23.0.1) for package: firefox-23.0.1-5.fc21.i686
---> Package xulrunner.i686 0:24.0-2.fc21 will be an update
--> Processing Conflict: firefox-23.0.1-5.fc21.i686 conflicts xulrunner(x86-32) > 23.1
--> Running transaction check
---> Package OpenEXR-libs.i686 0:1.7.1-6.fc20 will be updated
---> Package OpenEXR-libs.i686 0:2.0.1-1.fc21 will be an update
--> Processing Dependency: libIlmImf-Imf_2_0.so.20 for package: opencv-2.4.6.1-2.fc21.i686
--> Processing Dependency: libIlmImf-Imf_2_0.so.20 for package: ImageMagick-libs-6.8.6.3-4.fc21.i686
--> Processing Dependency: libIlmImf-Imf_2_0.so.20 for package: hugin-base-2012.0.0-11.fc21.i686
--> Processing Dependency: libIlmImf-Imf_2_0.so.20 for package: 6:kdelibs-4.11.1-3.fc21.i686
--> Processing Dependency: libIlmImf-Imf_2_0.so.20 for package: kde-runtime-libs-4.11.1-2.fc21.i686
---> Package ilmbase.i686 0:1.0.3-7.fc21 will be updated
---> Package ilmbase.i686 0:2.0.1-1.fc21 will be an update
--> Processing Dependency: libImath-2_0.so.10 for package: opencv-2.4.6.1-2.fc21.i686
--> Processing Dependency: libImath-2_0.so.10 for package: ImageMagick-libs-6.8.6.3-4.fc21.i686
--> Processing Dependency: libImath-2_0.so.10 for package: hugin-base-2012.0.0-11.fc21.i686
--> Processing Dependency: libImath-2_0.so.10 for package: 6:kdelibs-4.11.1-3.fc21.i686
--> Processing Dependency: libImath-2_0.so.10 for package: kde-runtime-libs-4.11.1-2.fc21.i686
--> Processing Dependency: libIlmThread-2_0.so.10 for package: opencv-2.4.6.1-2.fc21.i686
--> Processing Dependency: libIlmThread-2_0.so.10 for package: ImageMagick-libs-6.8.6.3-4.fc21.i686
--> Processing Dependency: libIlmThread-2_0.so.10 for package: hugin-base-2012.0.0-11.fc21.i686
--> Processing Dependency: libIlmThread-2_0.so.10 for package: 6:kdelibs-4.11.1-3.fc21.i686
--> Processing Dependency: libIlmThread-2_0.so.10 for package: kde-runtime-libs-4.11.1-2.fc21.i686
--> Processing Dependency: libIexMath-2_0.so.10 for package: ImageMagick-libs-6.8.6.3-4.fc21.i686
--> Processing Dependency: libIex-2_0.so.10 for package: opencv-2.4.6.1-2.fc21.i686
--> Processing Dependency: libIex-2_0.so.10 for package: ImageMagick-libs-6.8.6.3-4.fc21.i686
--> Processing Dependency: libIex-2_0.so.10 for package: hugin-base-2012.0.0-11.fc21.i686
--> Processing Dependency: libIex-2_0.so.10 for package: 6:kdelibs-4.11.1-3.fc21.i686
--> Processing Dependency: libIex-2_0.so.10 for package: kde-runtime-libs-4.11.1-2.fc21.i686
--> Processing Dependency: libHalf.so.10 for package: opencv-2.4.6.1-2.fc21.i686
--> Processing Dependency: libHalf.so.10 for package: ImageMagick-libs-6.8.6.3-4.fc21.i686
--> Processing Dependency: libHalf.so.10 for package: hugin-base-2012.0.0-11.fc21.i686
--> Processing Dependency: libHalf.so.10 for package: 6:kdelibs-4.11.1-3.fc21.i686
--> Processing Dependency: libHalf.so.10 for package: kde-runtime-libs-4.11.1-2.fc21.i686
---> Package xulrunner.i686 0:23.0.1-4.fc21 will be updated
---> Package xulrunner.i686 0:23.0.1-4.fc21 will be updated
---> Package xulrunner.i686 0:24.0-2.fc21 will be an update
--> Running transaction check
---> Package ImageMagick.i686 0:6.8.6.3-3.fc20 will be updated
---> Package kde-workspace.i686 0:4.11.1-1.fc21 will be updated
--> Processing Dependency: kde-workspace = 4.11.1-1.fc21 for package: kde-workspace-libs-4.11.1-1.fc21.i686
---> Package kde-workspace-ksplash-themes.noarch 0:4.11.1-1.fc21 will be updated
---> Package kde-workspace-ksplash-themes.noarch 0:4.11.1-2.fc21 will be an update
--> Processing Dependency: kde-workspace = 4.11.1-2.fc21 for package: kde-workspace-ksplash-themes-4.11.1-2.fc21.noarch
---> Package kdesdk-strigi-analyzers.i686 0:4.11.1-1.fc21 will be updated
---> Package kdm.i686 0:4.11.1-1.fc21 will be updated
---> Package ksysguard.i686 0:4.11.1-1.fc21 will be updated
---> Package kwin-gles-libs.i686 0:4.11.1-1.fc21 will be updated
--> Running transaction check
---> Package kde-workspace.i686 0:4.11.1-1.fc21 will be updated
---> Package kde-workspace-ksplash-themes.noarch 0:4.11.1-1.fc21 will be updated
---> Package kde-workspace-ksplash-themes.noarch 0:4.11.1-2.fc21 will be an update

Packages skipped because of dependency problems:
    ImageMagick-6.8.6.3-4.fc21.i686 from rawhide
    ImageMagick-libs-6.8.6.3-4.fc21.i686 from rawhide
    OpenEXR-libs-2.0.1-1.fc21.i686 from rawhide
    ghostscript-9.10-1.fc21.i686 from rawhide
    hugin-base-2012.0.0-11.fc21.i686 from rawhide
    ilmbase-2.0.1-1.fc21.i686 from rawhide
    kcm_colors-4.11.1-2.fc21.i686 from rawhide
    kde-runtime-4.11.1-2.fc21.i686 from rawhide
    kde-runtime-drkonqi-4.11.1-2.fc21.i686 from rawhide
    kde-runtime-flags-4.11.1-2.fc21.noarch from rawhide
    kde-runtime-libs-4.11.1-2.fc21.i686 from rawhide
    kde-workspace-4.11.1-2.fc21.i686 from rawhide
    kde-workspace-ksplash-themes-4.11.1-2.fc21.noarch from rawhide
    kde-workspace-libs-4.11.1-2.fc21.i686 from rawhide
    6:kdelibs-4.11.1-3.fc21.i686 from rawhide
    6:kdelibs-common-4.11.1-3.fc21.i686 from rawhide
    kdeplasma-addons-4.11.1-2.fc21.i686 from rawhide
    kdeplasma-addons-libs-4.11.1-2.fc21.i686 from rawhide
    kdesdk-strigi-analyzers-4.11.1-2.fc21.i686 from rawhide
    kdm-4.11.1-2.fc21.i686 from rawhide
    kgreeter-plugins-4.11.1-2.fc21.i686 from rawhide
    ksysguard-4.11.1-2.fc21.i686 from rawhide
    ksysguard-libs-4.11.1-2.fc21.i686 from rawhide
    ksysguardd-4.11.1-2.fc21.i686 from rawhide
    kwin-gles-libs-4.11.1-2.fc21.i686 from rawhide
    libkworkspace-4.11.1-2.fc21.i686 from rawhide
    lm_sensors-libs-3.3.4-8.fc21.i686 from rawhide
    opencv-2.4.6.1-2.fc21.i686 from rawhide
    opencv-core-2.4.6.1-2.fc21.i686 from rawhide
    1:perl-Encode-2.55-1.fc21.i686 from rawhide
    qtwebkit-2.3.2-3.fc21.i686 from rawhide
    xorg-x11-server-utils-7.7-4.fc21.i686 from rawhide
    xulrunner-24.0-2.fc21.i686 from rawhide


At least qtwebkit can be updated but it wasn't updated with --skip-broken

# yum update qtwebkit
Loaded plugins: refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package qtwebkit.i686 0:2.3.2-2.fc20 will be updated
---> Package qtwebkit.i686 0:2.3.2-3.fc21 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================================================================================
 Package                              Arch                             Version                                     Repository                           Size
=============================================================================================================================================================
Updating:
 qtwebkit                             i686                             2.3.2-3.fc21                                rawhide                              10 M

Transaction Summary
=============================================================================================================================================================
Upgrade  1 Package

Total download size: 10 M
Is this ok [y/d/N]: y
Downloading packages:
qtwebkit-2.3.2-3.fc21.i686.rpm                                                                                                        |  10 MB  00:00:16     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Updating   : qtwebkit-2.3.2-3.fc21.i686                                                                                                                1/2 
  Cleanup    : qtwebkit-2.3.2-2.fc20.i686                                                                                                                2/2 
  Verifying  : qtwebkit-2.3.2-3.fc21.i686                                                                                                                1/2 
  Verifying  : qtwebkit-2.3.2-2.fc20.i686                                                                                                                2/2 

Updated:
  qtwebkit.i686 0:2.3.2-3.fc21                                                                                                                               

Complete!
Comment 1 Jaroslav Reznik 2015-03-03 10:04:47 EST
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22
Comment 2 Fedora End Of Life 2016-07-19 06:24:22 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.