This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 100912 - scroll bars don't work when clicked, instead only work when dragged
scroll bars don't work when clicked, instead only work when dragged
Status: CLOSED NOTABUG
Product: Red Hat Linux Beta
Classification: Retired
Component: epiphany (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-26 20:10 EDT by George Karabin
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-03 11:12:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description George Karabin 2003-07-26 20:10:56 EDT
I'm running epiphany-0.8.0-1 on my Severn box and on my Redhat 9 + parts of
Rawhide box. On Severn, clicking on the scroll bar buttons or on "empty" space
in the scroll bar does not cause a window to scroll. However, this works just
fine on my RH9+RawhideParts box.

This is 100% reproducible for me. I haven't seen this problem on any other gtk2
applications.
Comment 1 George Karabin 2003-07-26 20:41:15 EDT
Also, my mouse wheel doesn't work in epiphany on Severn either, but it does in
other gtk2 applications.
Comment 2 George Karabin 2003-07-28 12:52:07 EDT
Hmm. I'm seeing a different symptom at the moment, after a reboot or two. I can
use the scroll bar empty space and the scroll buttons just fine now. The mouse
wheel only works until I click the cursor in an editable field of the browser,
like the comments field that I'm typing in right now. The mouse wheel will begin
functioning properly once I click anywhere else in the pane.

Also, smaller editable fields like the one to the right of "Bug x depends on" in
this bugzilla record don't seem to trigger the problem. Weird!
Comment 3 Christopher Blizzard 2003-08-26 13:12:34 EDT
This is working for me, just fine.  Are you using an odd gtk theme by any
chance?  Also, these are all stock builds, right?
Comment 4 George Karabin 2003-08-26 22:56:20 EDT
No, I'm using Bluecurve out of the box, across the board. I've been updating to
stock rawhide daily, and haven't seen a change in behavior this whole time. I
just created a new user account and tried it out, to make sure that nothing in
my configuration had become hosed. I see the same problem from the new user
account as well.

Because my original report was fairly crummy, let me resummarize how I produce
the bug:

1. Open this the URL for a bug, like this one, Bug #100912.
2. Click in the "Keywords" text box.
3. Use mouse wheel to scroll the page up and down (successfully).
4. Click in the "Additional Comments" text box.
5. Try to use mouse wheel to scroll the page up and down (doesn't work).

Hope that helps.
Comment 5 Christopher Blizzard 2003-09-03 11:12:13 EDT
Oh, that's not a bug.  That's just because textareas can be scrolled with the
mouse wheel while text inputs can't.  Fill up the entire text area so it
produces a scrollbar and scroll with the mouse and you'll see what I'm talking
about.
Comment 6 George Karabin 2003-09-03 11:16:58 EDT
Cool. I think that I just latched onto that after seeing the original
(unreproducible) symptoms.

Note You need to log in before you can comment on or make changes to this bug.