Bug 1009146 - Shutdown of VM results in full-screen display returning in windowed mode and unable to resize it from Windows -> Properties.
Shutdown of VM results in full-screen display returning in windowed mode and ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity medium
: rc
: 6.5
Assigned To: Virt Viewer Maint
Virtualization Bugs
:
Depends On:
Blocks: 1009648
  Show dependency treegraph
 
Reported: 2013-09-17 15:10 EDT by Bill Sanford
Modified: 2014-09-18 09:53 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-18 09:53:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Sanford 2013-09-17 15:10:51 EDT
Description of problem:
Started with:

Display 1 1024x768 (Windowed mode Monitor 1)
Display 2 1024x768 (Windowed mode Monitor 2)

Then I switched Display 2 to full-screen.
Display 1 1024x768 (Windowed mode Monitor 1)
Display 2 1920x1080 (Full-screen Monitor 2)

Shutdown the VM. 

Started same VM.

Both displays came up in Windowed mode. Display 1 is in Monitor 1 and Display 2 is mostly in Monitor 1. 

Took Display 2 that was in Windowed mode and tried to resize it to 1024x768 using the Windows Display Properties.

That is when Display 2 maximized itself in Monitor 1. 1920x979. As long as Display 2 was in Monitor 1, you could not resize Display 2.

I dragged the the maximized Display 2 to Monitor 2 and could only then set the resolution to 1024x768.

Version-Release number of selected component (if applicable):
rhev-guest-tools-iso-3.3-5.noarch.rpm
RHEL6.5-20130912.n.2
rhev-hypervisor6-6.5-20130910.2.el6ev.noarch.rpm
Windows XP VM
qxl-win-unsigned-0.1-18

How reproducible:
100%


Steps to Reproduce:
1.
2.
3.

Actual results:
In windowed mode, I wasn't able to resize a virt-viewer window with "Windows -> Prperties in the VM."

Expected results:
In windowed mode, I should be able to resize a virt-viewer window with "Windows -> Prperties in the VM."

Additional info:
Comment 1 David Blechter 2013-09-20 11:08:19 EDT
The bug was submitted during the rhel 6.5 testing. Moving to the RHEL for triage.
Comment 3 Marc-Andre Lureau 2013-09-21 11:17:18 EDT
How do you shut down the VM? Is the client restarted?

I couldn't reproduce resizing issue you described.
Comment 4 Bill Sanford 2013-09-23 12:01:06 EDT
I shutdown the VM through Windows Start Button.

This also happens in:

virt-viewer-0.5.6-7.el6.x86_64
rhev-guest-tools-iso-3.3-5.noarch.rpm
RHEL6.5-20130912.n.2
rhev-hypervisor6-6.5-20130910.2.el6ev.noarch.rpm
Windows 7x86 VM
Comment 5 Marc-Andre Lureau 2013-09-23 12:34:43 EDT
Is the client restarted?
Comment 6 Bill Sanford 2013-09-23 15:47:45 EDT
This is the issue prior to this bug:
https://bugzilla.redhat.com/show_bug.cgi?id=1009144
Comment 7 tingting zheng 2013-10-23 02:47:45 EDT
I can reproduce this issue with:
virt-viewer-0.5.6-7.el6.x86_64

Steps:
1.Use remote-viewer to launch a winxp guest from rhevm,enable 2 displays.
Display 1 1024x768 (Windowed mode Monitor 1)
Display 2 1024x768 (Windowed mode Monitor 2)

2.Switched Display 2 to full-screen.
Display 1 1024x768 (Windowed mode Monitor 1)
Display 2 1280x1024 (Full-screen Monitor 2)

3.In guest,click "Start"->"Power off".

4.Restart the guest on rhevm.

5.Use remote-viewer to launch the guest again.
Display 1 1024x768 (Windowed mode Monitor 1)
Display 2 1280x1024 (Windowed mode Monitor 1)

6.Once 2 displays are all in Monitor 1,I can not change the resolution of Display 2,it maximized itself as 1680*949.If I drag display on Monitor 2,I can resize it.

But I can not reproduce it with:
virt-viewer-0.5.6-8.el6.x86_64

Would you pls try the latest version of virt-viewer?
Comment 9 Bill Sanford 2013-12-12 16:31:03 EST
This is verified fixed in RHEV-M 3.3 (is26)
Comment 10 David Blechter 2014-09-18 09:53:21 EDT
The correct status is CLOSED CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.