Bug 1009302 - Installer: NullPointerException on Server Launch screen
Installer: NullPointerException on Server Launch screen
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Installer (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ER5
: EAP 6.2.0
Assigned To: Francisco Canas
Petr Kremensky
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 03:28 EDT by Petr Kremensky
Modified: 2014-09-03 00:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:17:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Kremensky 2013-09-18 03:28:21 EDT
Description of problem:
There is a problem in Server Launch screen. Select to start server in 'Standalone mode' by installer and to 'Launch browser after server startup'. After clicking on Next button NPE is thrown and installer is stuck. No exception is thrown if I choose 'Domain mode'.

Exception in thread "Thread-10" java.lang.NullPointerException
	at java.util.Hashtable.put(Hashtable.java:542)
	at java.util.Properties.setProperty(Properties.java:161)
	at com.izforge.izpack.installer.AutomatedInstallData.setVariable(AutomatedInstallData.java:231)
	at com.redhat.installer.action.PortDefaultReset.executeAction(PortDefaultReset.java:44)
	at com.izforge.izpack.installer.IzPanel.executePostValidationActions(IzPanel.java:1426)
	at com.izforge.izpack.installer.InstallerFrame.navigateNext(InstallerFrame.java:1653)
	at com.izforge.izpack.installer.InstallerFrame.navigateNext(InstallerFrame.java:1637)
	at com.izforge.izpack.installer.InstallerFrame$NavigationHandler.navigate(InstallerFrame.java:1800)
	at com.izforge.izpack.installer.InstallerFrame$NavigationHandler.access$100(InstallerFrame.java:1767)
	at com.izforge.izpack.installer.InstallerFrame$NavigationHandler$1.run(InstallerFrame.java:1784)
	at java.lang.Thread.run(Thread.java:722)



Version-Release number:
EAP 6.2.0.ER2
Comment 1 Thomas Hauser 2013-09-18 10:14:17 EDT
I am unable to reproduce this error using http://download.lab.bos.redhat.com/devel/candidates/JBEAP/JBEAP-6.2.0.ER2/jboss-eap-6.2.0.ER2-installer.jar 

Please give more information regarding choices made earlier in the installation.
Comment 2 Petr Kremensky 2013-09-18 10:41:07 EDT
I tried it several times now and it isn't as easy to reproduce as I thought. I was able to get the same exception (installer stuck) as in description just clicking on 'Domain mode' radio, but I hit this twice from 30+ tries. 

I am lowering the severity to medium (as I am unable to hit this every time). I'll try some more examples tomorrow and will let you know.
Comment 3 Petr Kremensky 2013-09-23 07:37:58 EDT
I'll try to reproduce this with ER3.
Comment 4 Petr Kremensky 2013-09-26 11:04:21 EDT
Finally I found a reliable way to reproduce this (EAP 6.2.0.ER3).
 1. Run the gui installation and navigate to Server Launch screen (use default values for all screens)
 2. Use Alt+n and Alt+p shortcuts to navigate between screens. Go to next (Logging Options) screen (Alt+n), return to Socket Bindings (2x Alt+p), go again to Logging Option (2x Alt+n) ... and repeat this until you hit the NPE (I hit this always on first returning to Server launch screen from Socket Binging screen with ER3)

I was able to hit this with RHEL6.4 and with Fedora 16
Comment 5 Petr Kremensky 2013-09-26 11:12:22 EDT
Alt+n and Alt+p keys here are used just for faster navigation, I can hit it also by clicking on Next/Previous buttons.
Comment 9 Francisco Canas 2013-10-11 13:41:37 EDT
This NPE was fixed for ER5, but wasn't marked. My apologies.

See commit for details:
http://git.app.eng.bos.redhat.com/jbossas-installer.git/commit/?h=eap-6.2&id=c927537bb1d2c2ce450ba51c0c0f1f333f6b6d1c
Comment 10 Petr Kremensky 2013-10-14 01:41:10 EDT
Verified on EAP 6.2.0.ER5 installer.

Note You need to log in before you can comment on or make changes to this bug.