Bug 100931 - FLAC should be included
Summary: FLAC should be included
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: grip   
(Show other bugs)
Version: beta1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-27 15:49 UTC by Need Real Name
Modified: 2014-03-17 02:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-12 06:53:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2003-07-27 15:49:44 UTC
Description of problem:
Please include FLAC, the Free Lossless Audio Codec, and its xmms plug-in.  The
current version of grip allows flac to be selected as the preferred encoder, but
then fails since the flac encoder isn't supplied.

Version-Release number of selected component (if applicable):
N/A

How reproducible:
Always

Steps to Reproduce:
1. Run "locate flac"
2. Observe that it's nowhere to be found
3.
    
Actual results:
bash: flac: command not found

Expected results:
flac should losslessly encode an audio file

Additional info:
If you do decide to include flac in an upcoming release, please build it with
ID3 support.

Comment 1 petrosyan 2003-07-30 02:53:05 UTC
here is a quote from flac's webpage ( http://flac.sourceforge.net/ ) 
 
When we say that FLAC is "Free" it means more than just that it is available at no 
cost. It means that the specification of the format is fully open to the public to be 
used for any purpose (the FLAC project reserves the right to set the FLAC 
specification and certify compliance), and that neither the FLAC format nor any of 
the implemented encoding/decoding methods are covered by any known patent. 
 

Comment 2 Phil Anderson 2004-01-12 06:11:15 UTC
This should be closed as the following packages are now in rawhide.
flac-1.1.0-1.i386.rpm
flac-xmms-1.1.0-1.i386.rpm
flac-devel-1.1.0-1.i386.rpm

Also, see bug 113291 about including the gstreamer plugin so that
sound-juicer will work.


Note You need to log in before you can comment on or make changes to this bug.