Bug 1009320 - Missing subform link after task execution
Missing subform link after task execution
Status: CLOSED NOTABUG
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Form Modeler (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pere Fernàndez
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 04:09 EDT by Pedro Zapata
Modified: 2013-09-18 07:08 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 07:08:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot 1 - Task executed but not completed (61.64 KB, image/png)
2013-09-18 04:09 EDT, Pedro Zapata
no flags Details
Screenshot 2 - Multiple Subform link lost (93.89 KB, image/png)
2013-09-18 04:10 EDT, Pedro Zapata
no flags Details

  None (edit)
Description Pedro Zapata 2013-09-18 04:09:54 EDT
Created attachment 799194 [details]
Screenshot 1 - Task executed but not completed

After a form with multiple subforms was executed (see screenshot 1), when changing again to the same non-completed task, the link to the subform definition is lost a no subform is displayed (see screenshot 2).

This apparently only happens with the new task execution UI in an independent panel, so all this task-form integration part must be reviewed again to see how it works with the new UI.
Comment 2 Pedro Zapata 2013-09-18 04:10:47 EDT
Created attachment 799195 [details]
Screenshot 2 - Multiple Subform link lost
Comment 3 Pedro Zapata 2013-09-18 04:12:35 EDT
Forgot to mention this happens in community version CR4 SNAPSHOT, but since this will get into product, this must be fixed before sync.
Comment 4 Pedro Zapata 2013-09-18 04:31:23 EDT
Also forgot to mention this can be tested by cloning the repository https://github.com/pzapata/kie-examples
Comment 5 Pedro Zapata 2013-09-18 07:08:55 EDT
It looks it was caused by a misconfiguration of subsecuent forms, it's not a bug then.

Note You need to log in before you can comment on or make changes to this bug.