Bug 1009365 - incorrect PGDATA path in /opt/rh/postgresql92/root/var/lib/pgsql/.bash_profile
incorrect PGDATA path in /opt/rh/postgresql92/root/var/lib/pgsql/.bash_profile
Status: CLOSED ERRATA
Product: Red Hat Software Collections
Classification: Red Hat
Component: postgresql (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.1
Assigned To: Pavel Raiskup
Jakub Prokes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 05:46 EDT by Jan Hutař
Modified: 2015-11-03 14:01 EST (History)
3 users (show)

See Also:
Fixed In Version: postgresql92-postgresql-9.2.5-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-04 02:44:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2013-09-18 05:46:32 EDT
Description of problem:
I have installed postgresql92-postgresql-server and noticed PGDATA in /opt/rh/postgresql92/root/var/lib/pgsql/.bash_profile points to /var/lib/pgsql/data, but I would expect it to point to /opt/rh/postgresql92/root/var/lib/pgsql/data/.


Version-Release number of selected component (if applicable):
postgresql92-postgresql-server-9.2.4-7.el6.x86_64


How reproducible:
always


Steps to Reproduce:
1. Install postgresql92-postgresql-server-9.2.4-7.el6.x86_64
2. # cat /opt/rh/postgresql92/root/var/lib/pgsql/.bash_profile


Actual results:
[ -f /etc/profile ] && source /etc/profile

PGDATA=/var/lib/pgsql/data
export PGDATA


Expected results:
[ -f /etc/profile ] && source /etc/profile

PGDATA=/opt/rh/postgresql92/root/var/lib/pgsql/data
export PGDATA


Additional info:
Maybe this is on purpose? It just seems to be strange to me.
Comment 5 errata-xmlrpc 2014-06-04 02:44:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0616.html

Note You need to log in before you can comment on or make changes to this bug.