Bug 1009374 - [abrt] systemd-207-2.fc21: log_assert: Process /usr/lib/systemd/systemd-logind was killed by signal 6 (SIGABRT)
[abrt] systemd-207-2.fc21: log_assert: Process /usr/lib/systemd/systemd-login...
Status: CLOSED DUPLICATE of bug 1008907
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
abrt_hash:5821e87291d9e5e325518fd9899...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 06:13 EDT by Christopher Meng
Modified: 2013-09-18 08:39 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 08:39:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (6.97 KB, text/plain)
2013-09-18 06:13 EDT, Christopher Meng
no flags Details
File: cgroup (152 bytes, text/plain)
2013-09-18 06:13 EDT, Christopher Meng
no flags Details
File: core_backtrace (3.42 KB, text/plain)
2013-09-18 06:13 EDT, Christopher Meng
no flags Details
File: dso_list (1.29 KB, text/plain)
2013-09-18 06:13 EDT, Christopher Meng
no flags Details
File: environ (186 bytes, text/plain)
2013-09-18 06:13 EDT, Christopher Meng
no flags Details
File: limits (1.29 KB, text/plain)
2013-09-18 06:13 EDT, Christopher Meng
no flags Details
File: maps (4.13 KB, text/plain)
2013-09-18 06:13 EDT, Christopher Meng
no flags Details
File: open_fds (1.59 KB, text/plain)
2013-09-18 06:13 EDT, Christopher Meng
no flags Details
File: proc_pid_status (758 bytes, text/plain)
2013-09-18 06:13 EDT, Christopher Meng
no flags Details
File: var_log_messages (7.23 KB, text/plain)
2013-09-18 06:13 EDT, Christopher Meng
no flags Details

  None (edit)
Description Christopher Meng 2013-09-18 06:13:06 EDT
Version-Release number of selected component:
systemd-207-2.fc21

Additional info:
reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        /usr/lib/systemd/systemd-logind
crash_function: log_assert
executable:     /usr/lib/systemd/systemd-logind
kernel:         3.12.0-0.rc0.git26.2.fc21.i686+PAE
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (8 frames)
 #3 log_assert at ../src/shared/log.c:699
 #4 log_assert_failed at ../src/shared/log.c:704
 #5 session_new at ../src/login/logind-session.c:44
 #6 manager_add_session at ../src/login/logind.c:249
 #7 bus_manager_create_session at ../src/login/logind-dbus.c:582
 #8 manager_message_handler at ../src/login/logind-dbus.c:1722
 #9 _dbus_object_tree_dispatch_and_unlock at dbus-object-tree.c:862
 #11 manager_run at ../src/login/logind.c:1516
Comment 1 Christopher Meng 2013-09-18 06:13:12 EDT
Created attachment 799268 [details]
File: backtrace
Comment 2 Christopher Meng 2013-09-18 06:13:17 EDT
Created attachment 799269 [details]
File: cgroup
Comment 3 Christopher Meng 2013-09-18 06:13:22 EDT
Created attachment 799270 [details]
File: core_backtrace
Comment 4 Christopher Meng 2013-09-18 06:13:27 EDT
Created attachment 799271 [details]
File: dso_list
Comment 5 Christopher Meng 2013-09-18 06:13:31 EDT
Created attachment 799272 [details]
File: environ
Comment 6 Christopher Meng 2013-09-18 06:13:36 EDT
Created attachment 799273 [details]
File: limits
Comment 7 Christopher Meng 2013-09-18 06:13:41 EDT
Created attachment 799274 [details]
File: maps
Comment 8 Christopher Meng 2013-09-18 06:13:46 EDT
Created attachment 799276 [details]
File: open_fds
Comment 9 Christopher Meng 2013-09-18 06:13:51 EDT
Created attachment 799277 [details]
File: proc_pid_status
Comment 10 Christopher Meng 2013-09-18 06:13:56 EDT
Created attachment 799278 [details]
File: var_log_messages
Comment 11 Lukáš Nykrýn 2013-09-18 08:17:01 EDT
This looks weird.

manager_add_session() has assert(m) and assert(id)
then it calls session_new(m, id);
and here in session_new(m, id) assert(id) fails?
Comment 12 Michal Schmidt 2013-09-18 08:20:27 EDT
The failed assertion is "session_id_valid(id)".

"Assertion 'session_id_valid(id)' failed at ../src/login/logind-session.c:44, function session_new(). Aborting."
Comment 13 Zbigniew Jędrzejewski-Szmek 2013-09-18 08:39:53 EDT

*** This bug has been marked as a duplicate of bug 1008907 ***

Note You need to log in before you can comment on or make changes to this bug.