Bug 1009376 - anaconda-ks.cfg doesn't contain proper bonding configuration
anaconda-ks.cfg doesn't contain proper bonding configuration
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.5
Unspecified Linux
medium Severity medium
: rc
: ---
Assigned To: Radek Vykydal
Release Test Team
:
: 1003864 (view as bug list)
Depends On:
Blocks: 972747
  Show dependency treegraph
 
Reported: 2013-09-18 06:15 EDT by Alexander Todorov
Modified: 2014-10-14 02:39 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-13.21.217-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 02:39:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.ifcfg.log (7.14 KB, text/plain)
2013-09-18 06:17 EDT, Alexander Todorov
no flags Details
anaconda.log (30.54 KB, text/plain)
2013-09-18 06:18 EDT, Alexander Todorov
no flags Details
anaconda.program.log (55.51 KB, text/plain)
2013-09-18 06:18 EDT, Alexander Todorov
no flags Details
anaconda.storage.log (223.10 KB, text/plain)
2013-09-18 06:18 EDT, Alexander Todorov
no flags Details
anaconda.syslog (92.75 KB, text/plain)
2013-09-18 06:18 EDT, Alexander Todorov
no flags Details
anaconda.xlog (28.88 KB, text/plain)
2013-09-18 06:18 EDT, Alexander Todorov
no flags Details
anaconda.yum.log (42.13 KB, text/plain)
2013-09-18 06:19 EDT, Alexander Todorov
no flags Details
a patch with fix (1.07 KB, patch)
2014-05-06 09:13 EDT, Radek Vykydal
no flags Details | Diff

  None (edit)
Description Alexander Todorov 2013-09-18 06:15:17 EDT
One of our test cases uses bonding configuration and the resulting ks.cfg is not the same as the one passed to anaconda.

Version-Release number of selected component (if applicable):
anaconda-13.21.206-1.el6.x86_64
RHEL6.5-20130913.0

Steps to Reproduce: 
 1. Obtain a machine with two Ethernet ports connected to an Ethernet switch


 1. Start kickstart installation of the system 
 2. Ensure that kickstart contains
      + network --bootproto=dhcp --device=bond0 --bondslaves=eth0,eth1 --bondopts=mode=balance-rr,arp_interval=100,arp_ip_target=ddd.ddd.ddd.ddd


where ddd.ddd.ddd.ddd is the IP address of the default GW for the network. 

 3. Ensure that bond has been set up properly during installation in %post

 4. Also check bond setup on  the installed system



Expected results:
 1. Installation should pass without errors
 2. Bond has been properly set up either during the installation and on the
    installed system

 3. After system is installed check network statement in /root/anaconda-ks.cfg,
    it should contain all channel bonding specific options specified in the
    original ks.


This contains:
 
network --onboot yes --device bond0 --mtu=1500 --bootproto dhcp
network --onboot yes --device eth0 --noipv4 --noipv6
network --onboot yes --device eth1 --noipv4 --noipv6



You can check above mentioned setup by inspecting:

  * /sys/class/net/bond0/bonding/slaves - should contain

    eth0,eth1

  * /sys/class/net/bond0/bonding/mode should contain
    balance-rr and/or 0

  * /sys/class/net/bond0/bonding/arp_interval should contain 100
  * /sys/class/net/bond0/bonding/arp_ip_target should contain ddd.ddd.ddd.ddd


^^^^ this was all correct on the installed system.
Comment 1 Alexander Todorov 2013-09-18 06:17:37 EDT
Created attachment 799280 [details]
anaconda.ifcfg.log
Comment 2 Alexander Todorov 2013-09-18 06:18:00 EDT
Created attachment 799281 [details]
anaconda.log
Comment 3 Alexander Todorov 2013-09-18 06:18:18 EDT
Created attachment 799282 [details]
anaconda.program.log
Comment 4 Alexander Todorov 2013-09-18 06:18:33 EDT
Created attachment 799284 [details]
anaconda.storage.log
Comment 5 Alexander Todorov 2013-09-18 06:18:41 EDT
Created attachment 799287 [details]
anaconda.syslog
Comment 6 Alexander Todorov 2013-09-18 06:18:57 EDT
Created attachment 799292 [details]
anaconda.xlog
Comment 7 Alexander Todorov 2013-09-18 06:19:19 EDT
Created attachment 799295 [details]
anaconda.yum.log
Comment 8 Radek Vykydal 2013-09-24 03:52:15 EDT
*** Bug 1003864 has been marked as a duplicate of this bug. ***
Comment 9 RHEL Product and Program Management 2013-10-13 22:05:59 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 11 Radek Vykydal 2014-05-06 09:13:36 EDT
Created attachment 892861 [details]
a patch with fix

Updates image for testing with the patch can be applied to rhel 6.5 by adding

udpates=http://rvykydal.fedorapeople.org/updates.1009376bondgenks.img

installer boot option.
Comment 14 errata-xmlrpc 2014-10-14 02:39:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1380.html

Note You need to log in before you can comment on or make changes to this bug.