Bug 1009418 - Error when deploying quickstarts from JBDS
Error when deploying quickstarts from JBDS
Status: CLOSED WORKSFORME
Product: JBoss Enterprise Portal Platform 6
Classification: JBoss
Component: Quickstarts (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ER01
: 6.1.1
Assigned To: Peter Palaga
Dominik Pospisil
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 07:50 EDT by Filip Kiss
Modified: 2014-01-02 03:50 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-20 08:03:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server log (265.88 KB, text/x-log)
2013-09-18 07:51 EDT, Filip Kiss
no flags Details

  None (edit)
Description Filip Kiss 2013-09-18 07:50:17 EDT
Description of problem:
There are errors when deploying qs from JBDS 7.1.0.Alpha1 to Portal (6.1.0.ER05). See log in the attachment. Server log shows that qs is deployed, but after importing apps in app register it is not displayed.
Comment 2 Filip Kiss 2013-09-18 07:51:03 EDT
Created attachment 799343 [details]
server log
Comment 3 Peter Palaga 2013-11-01 08:39:34 EDT
I could not reproduce this with JBDS 7.1.0.Beta1-v20131026-0928-B470 and JPP 6.1 GA. The newest quickstarts which were published for JBDS about a week ago work fine.
Comment 4 Filip Kiss 2013-12-12 09:25:13 EST
Tested now on 7.1.0.GA-v20131208-0703-B592 with DR02 JPP + DR02 QS manually imported to IDE and also with QS from project examples - same exceptions in server output log. After importing JSF QS to IDE there is a message: 

"An internal error occurred during: "Loading descriptor for jsf2-rf4-hello-world-portlet.".org.eclipse.emf.ecore.xmi.FeatureNotFoundException: Feature 'context-param' not found. (platform:/resource/jsf2-rf4-hello-world-portlet/src/main/webapp/WEB-INF/web.xml, 29, 20)"
Comment 5 Peter Palaga 2013-12-20 08:03:17 EST
I still cannot reproduce this. I used JBoss Portal 6.1.1.DR2 and associated quickstarts plus JBDS 7.1.GA. 
Here is what I do: https://www.youtube.com/watch?v=AMVXfRKtRgo
Filip, could you please go through the screencast and eventually tell what you do differently? Maybe you are not cleaning the Eclipse workspace directory you use? The message you mention sounds like some broken file in your .settings directory.
Comment 6 Filip Kiss 2014-01-02 03:50:26 EST
Hi Peter, thanks for your detailed video. I reinstalled JBDS, deleted workspace re-set maven settings.xml file and now it seems to work for me. Thanks.

Note You need to log in before you can comment on or make changes to this bug.