Bug 1009465 - Creating duplicate XLS Decision Table fails with ugly error popup
Creating duplicate XLS Decision Table fails with ugly error popup
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER2
: 6.0.1
Assigned To: manstis
Lukáš Petrovický
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 10:01 EDT by Zuzana Krejčová
Modified: 2014-08-06 15:59 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 15:59:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error popup (33.40 KB, image/png)
2013-09-18 10:01 EDT, Zuzana Krejčová
no flags Details
server log excerpt - same xls dt twice and resulting stacktrace (14.39 KB, text/x-log)
2013-09-18 10:01 EDT, Zuzana Krejčová
no flags Details
6.0.1 ER1 stacktrace - server log excerpt (22.34 KB, text/x-log)
2014-02-28 04:49 EST, Zuzana Krejčová
no flags Details
6.0.1 ER1 stacktrace - unformatted error pop-up (194.55 KB, image/png)
2014-02-28 04:53 EST, Zuzana Krejčová
no flags Details

  None (edit)
Description Zuzana Krejčová 2013-09-18 10:01:11 EDT
Created attachment 799392 [details]
error popup

Description of problem:
Creating a XLS Decision Table with a name that is already used in the current package fails, but instead of a sensible message that the file already exists, you get a pop-up with an unformatted html and error stacktrace - see screenshot.


Version-Release number of selected component (if applicable):
BPMS 6.0 ER3
Comment 1 Zuzana Krejčová 2013-09-18 10:01:51 EDT
Created attachment 799393 [details]
server log excerpt - same xls dt twice and resulting stacktrace
Comment 7 Zuzana Krejčová 2013-12-09 05:38:50 EST
Verified in ER5, with a tiny problem with the alert message, see bug 1039521.
Comment 8 Zuzana Krejčová 2014-02-28 04:44:58 EST
There is a regression in BPMS 6.0.1 ER1. The message is different though, as well as the stacktrace - attachments will follow.
Comment 9 Zuzana Krejčová 2014-02-28 04:49:48 EST
Created attachment 868933 [details]
6.0.1 ER1 stacktrace - server log excerpt
Comment 10 Zuzana Krejčová 2014-02-28 04:53:10 EST
Created attachment 868935 [details]
6.0.1 ER1 stacktrace - unformatted error pop-up

Unable to complete your request. The following exception occurred: <h1>JBWEB000065: HTTP Status 500 - </h1><hr noshade="noshade" size="1"><p><b>JBWEB000309: type</b> JBWEB000066: Exception report</p><p><b>JBWEB000068: message</b> <u></u></p><p><b>JBWEB000069: description</b> <u>JBWEB000145: The server encountered an internal error that prevented it from fulfilling this request.</u></p><p><b>JBWEB000070: exception</b> </p><pre>javax.enterprise.event.ObserverException
...
</pre><p></p><p><b>JBWEB000071: root cause</b> </p><pre>java.lang.IllegalAccessError: tried to access method org.jboss.solder.exception.control.ExceptionStack.dropCause()V from class org.jboss.solder.exception.control.ExceptionHandlerDispatch
...
</pre><p></p><p><b>JBWEB000072: note</b> <u>JBWEB000073: The full stack trace of the root cause is available in the JBoss Web/7.2.2.Final-redhat-1 logs.</u></p><hr noshade="noshade" size="1"><h3>JBoss Web/7.2.2.Final-redhat-1</h3>.
Comment 11 manstis 2014-03-03 05:42:25 EST
I cannot replicate with the latest codebase (6.0.1.ER2). Please re-try.
Comment 12 Jiri Locker 2014-03-06 06:04:09 EST
Confirming the issue is not present in 6.0.1.ER2.

Proposing 6.0.1 release flag.
Comment 13 Lukáš Petrovický 2014-03-06 06:41:26 EST
In that case, VERIFIED in ER2.

Note You need to log in before you can comment on or make changes to this bug.