Bug 1009503 - Missing build requires for perl516-perl-threads - needs perl516-perl(Thread::Queue)
Missing build requires for perl516-perl-threads - needs perl516-perl(Thread::...
Status: CLOSED ERRATA
Product: Red Hat Software Collections
Classification: Red Hat
Component: perl-threads (Show other bugs)
perl516
All All
unspecified Severity low
: ---
: 1.1
Assigned To: perl-maint-list
Martin Kyral
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 10:41 EDT by jcpunk
Modified: 2014-06-04 03:20 EDT (History)
4 users (show)

See Also:
Fixed In Version: perl516-perl-threads-1.87-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-04 03:20:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0613 normal SHIPPED_LIVE perl516 bug fix and enhancement update 2014-06-04 06:59:05 EDT

  None (edit)
Description jcpunk 2013-09-18 10:41:33 EDT
Description of problem: make test from %check requires Thread/Queue.pm which is provided by perl516-perl-Thread-Queue-3.02-1.el6.noarch.rpm

The BuildRequires for this rpm should add perl516-perl(Thread::Queue) so that the %check can complete successfully


Version-Release number of selected component (if applicable): perl516-perl-threads-1.86-100.el6


How reproducible: 100%


Steps to Reproduce:
1. build with mock, populating only what is required by the rpm
2. %check fails

Actual results:
t/exit.t ........... ok
Can't locate Thread/Queue.pm in @INC (@INC contains: /builddir/build/BUILD/threads-1.86/blib/arch /builddir/build/BUILD/threads-1.86/blib/lib /opt/rh/perl516/root/usr/local/lib/perl5 /opt/rh/perl516/root/usr/local/share/perl5 /opt/rh/perl516/root/usr/lib/perl5/vendor_perl /opt/rh/perl516/root/usr/share/perl5/vendor_perl /opt/rh/perl516/root/usr/lib/perl5 /opt/rh/perl516/root/usr/share/perl5 .) at t/free.t line 26.
BEGIN failed--compilation aborted at t/free.t line 30.
t/free.t ........... 
Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
Can't locate Thread/Queue.pm in @INC (@INC contains: /builddir/build/BUILD/threads-1.86/blib/arch /builddir/build/BUILD/threads-1.86/blib/lib /opt/rh/perl516/root/usr/local/lib/perl5 /opt/rh/perl516/root/usr/local/share/perl5 /opt/rh/perl516/root/usr/lib/perl5/vendor_perl /opt/rh/perl516/root/usr/share/perl5/vendor_perl /opt/rh/perl516/root/usr/lib/perl5 /opt/rh/perl516/root/usr/share/perl5 .) at t/free2.t line 30.
BEGIN failed--compilation aborted at t/free2.t line 34.
t/free2.t .......... 
Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/join.t ........... ok
Can't locate Thread/Queue.pm in @INC (@INC contains: /builddir/build/BUILD/threads-1.86/blib/arch /builddir/build/BUILD/threads-1.86/blib/lib /opt/rh/perl516/root/usr/local/lib/perl5 /opt/rh/perl516/root/usr/local/share/perl5 /opt/rh/perl516/root/usr/lib/perl5/vendor_perl /opt/rh/perl516/root/usr/share/perl5/vendor_perl /opt/rh/perl516/root/usr/lib/perl5 /opt/rh/perl516/root/usr/share/perl5 .) at t/kill.t line 31.
BEGIN failed--compilation aborted at t/kill.t line 36.

Expected results:
Thread/Queue.pm should be required by the rpm
BuildRequires: perl516-perl(Thread::Queue) 
should be added

Additional info:
Comment 5 errata-xmlrpc 2014-06-04 03:20:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0613.html

Note You need to log in before you can comment on or make changes to this bug.