Bug 1009514 - Missing build requires for perl516-perl-DBD-Pg - needs perl516-perl(Time::HiRes)
Missing build requires for perl516-perl-DBD-Pg - needs perl516-perl(Time::HiRes)
Status: CLOSED ERRATA
Product: Red Hat Software Collections
Classification: Red Hat
Component: perl-DBD-Pg (Show other bugs)
perl516
All All
unspecified Severity low
: ---
: 1.1
Assigned To: perl-maint-list
Martin Kyral
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 10:57 EDT by jcpunk
Modified: 2014-06-04 03:20 EDT (History)
4 users (show)

See Also:
Fixed In Version: perl-DBD-Pg-2.19.3-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-04 03:20:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jcpunk 2013-09-18 10:57:18 EDT
Description of problem: make test from %check requires Time/HiRes.pm which is provided by perl516-perl-Time-HiRes-0:1.9725-12.el6

Version-Release number of selected component (if applicable):perl516-perl-DBD-Pg-2.19.3-1.el6


How reproducible: 100%


Steps to Reproduce:
1.build with mock, populating only what is required by the rpm
2.%check fails

Actual results:
t/07copy.t .......... ok
Can't locate Time/HiRes.pm in @INC (@INC contains: /builddir/build/BUILD/DBD-Pg-2.19.3/blib/lib /builddir/build/BUILD/DBD-Pg-2.19.3/blib/arch /opt/rh/perl516/root/usr/local/lib64/perl5 /opt/rh/perl516/root/usr/local/share/perl5 /opt/rh/perl516/root/usr/lib64/perl5/vendor_perl /opt/rh/perl516/root/usr/share/perl5/vendor_perl /opt/rh/perl516/root/usr/lib64/perl5 /opt/rh/perl516/root/usr/share/perl5 .) at t/08async.t line 9.
BEGIN failed--compilation aborted at t/08async.t line 9.
t/08async.t ......... 
Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/09arrays.t ........ ok

Expected results:
Time/HiRes.pm present
BuildRequires: perl516-perl(Time::HiRes)
should be added

Additional info:
Comment 5 errata-xmlrpc 2014-06-04 03:20:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0613.html

Note You need to log in before you can comment on or make changes to this bug.