Bug 1009532 - Abrt reporting bugs as a "private" mark
Abrt reporting bugs as a "private" mark
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
20
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 11:14 EDT by Onuralp SEZER
Modified: 2016-11-30 19:45 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-06 11:48:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Onuralp SEZER 2013-09-18 11:14:33 EDT
Description of problem:
Abrt reporting bugs as a "private" mark and permanent. Reporter can't even chanage "private" button because It's also disabled.

Fedora 20 user reported bugs can be also private and making problem. Because no one can't even see it also without report we can't determine fedora 20 problems. 

The bugs I reported and checked "private ; 

https://bugzilla.redhat.com/show_bug.cgi?id=a1008706
https://bugzilla.redhat.com/show_bug.cgi?id=1008897

If It's happened again. I will post every bugs to here.
Comment 1 Onuralp SEZER 2013-09-18 11:18:02 EDT
Another bug marked "private" ; 

https://bugzilla.redhat.com/show_bug.cgi?id=1008079
Comment 2 Jakub Filak 2013-09-19 05:06:02 EDT
Thank you for the bug report! It looks like that abrt incorrectly interprets configuration options. abrt thinks that you've requested to create a bug report with restricted access because of possibly sensitive data were detected and along with that request you wanted abrt to remember your decision.

Could you please run the following command and submit the output here:

$ grep ABRT_CREATE_PRIVATE_TICKET $HOME/.config/abrt/settings/report-gtk.conf
Comment 3 Onuralp SEZER 2013-09-19 05:55:42 EDT
Result was coming nothing all output just this 2 lines. 

thunderbirdtr@heisenbug settings$ cat report-gtk.conf 

abrt_analyze_smart_ask_perform_local_analysis = "yes"
abrt_analyze_smart_ask_upload_coredump = "yes"
Comment 4 Jakub Filak 2013-09-23 10:52:18 EDT
I am sorry, but I am not able to reproduce this bug (see bug #1011000). ABRT does not mark the report as private unless I explicitly require it. It means that I click Yes button on the dialogue asking me if I want to restrict access to the report. Are you sure that you click No button on that dialogue? It would be nice if you could upload a demonstrative video [1].


1: https://fedoraproject.org/wiki/Bugs_and_feature_requests?rd=BugsAndFeatureRequests#Graphical_User_Interfaces
Comment 5 Onuralp SEZER 2013-09-23 12:31:52 EDT
I select "no" for restriction and done now It's working. no need to screencast. 

Thank you.
Comment 6 Jakub Filak 2013-09-24 03:06:23 EDT
Per comment #5, setting this report to CLOSED:NOTABUG.
Comment 7 leigh scott 2013-12-06 09:43:24 EST
abrt shouldn't have the ability to mark bugs private.
I refuse to work all bugs marked private (I can't forward them upstream) and close them as not a bug.

https://bugzilla.redhat.com/show_bug.cgi?id=960549


I have closed dozens of reports due to this issue.

https://bugzilla.redhat.com/show_bug.cgi?id=1039060


Please remove this option altogether or add all my packages to the abrt blacklist!!!
Comment 8 Jakub Filak 2013-12-06 10:29:59 EST
I agree that abrt should much more carefully examine the data before offering users to create a private report. We already have a bug report opened for this issue (bug #1009730). I would close this particular bug report as NOTABUG, if you don't mind.
Comment 9 leigh scott 2013-12-06 11:48:09 EST
(In reply to Jakub Filak from comment #8)
> I agree that abrt should much more carefully examine the data before
> offering users to create a private report. We already have a bug report
> opened for this issue (bug #1009730). I would close this particular bug
> report as NOTABUG, if you don't mind.

No problem

Note You need to log in before you can comment on or make changes to this bug.