Bug 1009612 - IOException: Input/output error during read on /dev/sda
IOException: Input/output error during read on /dev/sda
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:04bcc6eff86cdc2b71b0d371968...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 13:22 EDT by Chuck Forsberg
Modified: 2013-10-12 14:00 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1053281 (view as bug list)
Environment:
Last Closed: 2013-09-18 13:26:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda.log (28.43 KB, text/plain)
2013-09-18 13:22 EDT, Chuck Forsberg
no flags Details
File: environ (492 bytes, text/plain)
2013-09-18 13:22 EDT, Chuck Forsberg
no flags Details
File: lsblk_output (1.42 KB, text/plain)
2013-09-18 13:22 EDT, Chuck Forsberg
no flags Details
File: nmcli_dev_list (4.61 KB, text/plain)
2013-09-18 13:22 EDT, Chuck Forsberg
no flags Details
File: os_info (291 bytes, text/plain)
2013-09-18 13:22 EDT, Chuck Forsberg
no flags Details
File: program.log (28.42 KB, text/plain)
2013-09-18 13:22 EDT, Chuck Forsberg
no flags Details
File: storage.log (136.92 KB, text/plain)
2013-09-18 13:22 EDT, Chuck Forsberg
no flags Details
File: syslog (523.39 KB, text/plain)
2013-09-18 13:22 EDT, Chuck Forsberg
no flags Details
File: ifcfg.log (484 bytes, text/plain)
2013-09-18 13:22 EDT, Chuck Forsberg
no flags Details
File: packaging.log (1.25 MB, text/plain)
2013-09-18 13:22 EDT, Chuck Forsberg
no flags Details
File: anaconda-tb (1.97 MB, text/plain)
2013-09-18 13:22 EDT, Chuck Forsberg
no flags Details

  None (edit)
Description Chuck Forsberg 2013-09-18 13:22:07 EDT
Version-Release number of selected component:
anaconda-20.15-1

The following was filed automatically by anaconda:
anaconda 20.15-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/parted/disk.py", line 213, in commit
    return self.__disk.commit()
  File "/usr/lib64/python2.7/site-packages/parted/decorators.py", line 41, in new
    ret = fn(*args, **kwds)
  File "/usr/lib/python2.7/site-packages/blivet/formats/disklabel.py", line 292, in commit
    self.partedDisk.commit()
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 1605, in _destroy
    self.disk.originalFormat.commit()
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 822, in destroy
    self._destroy()
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 318, in execute
    self.device.destroy()
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 310, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 169, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 142, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
IOException: Input/output error during read on /dev/sda

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img ramdisk_size=9216 root=live:http://192.168.1.13/squashfs.img repo=http://192.168.1.13/fc20/os BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Alpha

Potential duplicate: bug 973747
Comment 1 Chuck Forsberg 2013-09-18 13:22:11 EDT
Created attachment 799502 [details]
File: anaconda.log
Comment 2 Chuck Forsberg 2013-09-18 13:22:16 EDT
Created attachment 799503 [details]
File: environ
Comment 3 Chuck Forsberg 2013-09-18 13:22:19 EDT
Created attachment 799504 [details]
File: lsblk_output
Comment 4 Chuck Forsberg 2013-09-18 13:22:23 EDT
Created attachment 799505 [details]
File: nmcli_dev_list
Comment 5 Chuck Forsberg 2013-09-18 13:22:26 EDT
Created attachment 799506 [details]
File: os_info
Comment 6 Chuck Forsberg 2013-09-18 13:22:29 EDT
Created attachment 799507 [details]
File: program.log
Comment 7 Chuck Forsberg 2013-09-18 13:22:32 EDT
Created attachment 799508 [details]
File: storage.log
Comment 8 Chuck Forsberg 2013-09-18 13:22:37 EDT
Created attachment 799509 [details]
File: syslog
Comment 9 Chuck Forsberg 2013-09-18 13:22:41 EDT
Created attachment 799510 [details]
File: ifcfg.log
Comment 10 Chuck Forsberg 2013-09-18 13:22:45 EDT
Created attachment 799511 [details]
File: packaging.log
Comment 11 Chuck Forsberg 2013-09-18 13:22:51 EDT
Created attachment 799512 [details]
File: anaconda-tb
Comment 12 David Shea 2013-09-18 13:26:50 EDT
There appears to be a problem with your drive. In syslog:

17:18:08,361 ERR kernel:[   48.148036] ata6.00: failed command: READ FPDMA QUEUED
17:18:08,361 ERR kernel:[   48.148041] ata6.00: cmd 60/08:08:10:28:d0/00:00:09:00:00/40 tag 1 ncq 4096 in
17:18:08,361 ERR kernel:[   48.148041]          res 40/00:f0:f8:28:d0/00:00:09:00:00/40 Emask 0x1 (device error)
17:18:08,361 ERR kernel:[   48.148044] ata6.00: status: { DRDY }
Comment 13 oliver.zemann 2013-10-12 14:00:23 EDT
this is a bug, i have the exact same error message.
my drive is monitored by SMART and has no error.
closing bugs as "not a bug" will prevent others in reporting the same behaviour as the reporting tool in f20 only checks the state of the existing one and then aborts without sending the relevant data.

fedora goes more and more into an unstable state where i think about switching to another distri, even if i liked fedora a lot.

Note You need to log in before you can comment on or make changes to this bug.