Bug 1009662 - LVMError: lvresize failed for 02: running lvm lvresize --force -L 9980m --config devices { filter=["r|/loop3$|","r|/loop4$|","r|/loop5$|","r|/loop6$|","r|/loop7$|"] } fedora/02 failed
LVMError: lvresize failed for 02: running lvm lvresize --force -L 9980m --con...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:87dc9bcbcf582be09c08ea01f82...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 15:55 EDT by Emmett Culley
Modified: 2014-12-02 14:06 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-02 14:06:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (875.59 KB, text/plain)
2013-09-18 15:55 EDT, Emmett Culley
no flags Details
File: anaconda.log (185.88 KB, text/plain)
2013-09-18 15:55 EDT, Emmett Culley
no flags Details
File: environ (441 bytes, text/plain)
2013-09-18 15:55 EDT, Emmett Culley
no flags Details
File: lsblk_output (1.86 KB, text/plain)
2013-09-18 15:55 EDT, Emmett Culley
no flags Details
File: nmcli_dev_list (11.78 KB, text/plain)
2013-09-18 15:55 EDT, Emmett Culley
no flags Details
File: os_info (179 bytes, text/plain)
2013-09-18 15:55 EDT, Emmett Culley
no flags Details
File: program.log (58.88 KB, text/plain)
2013-09-18 15:55 EDT, Emmett Culley
no flags Details
File: storage.log (325.96 KB, text/plain)
2013-09-18 15:55 EDT, Emmett Culley
no flags Details
File: syslog (114.88 KB, text/plain)
2013-09-18 15:55 EDT, Emmett Culley
no flags Details
File: ifcfg.log (573 bytes, text/plain)
2013-09-18 15:56 EDT, Emmett Culley
no flags Details
File: packaging.log (174.43 KB, text/plain)
2013-09-18 15:56 EDT, Emmett Culley
no flags Details

  None (edit)
Description Emmett Culley 2013-09-18 15:55:19 EDT
Description of problem:
Again while attempting to do a custom partitioning.  This time I attempted to reuse that partitions I had created during previous installation attempt.

/boot = ext2
/home = LVM ext4
/var = LVM ext4
/ = LVM ext4
swap

System has two partitions set up by previous win 7 installation with main partion shrunk via gparted boot disk to 117 GB.

I will attempt to prepartition the disk via gparted then boot to rescue and forpamt partitions.

Version-Release number of selected component:
anaconda-19.30.13-1

The following was filed automatically by anaconda:
anaconda 19.30.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devicelibs/lvm.py", line 384, in lvresize
    raise LVMError("lvresize failed for %s: %s" % (lv_name, msg))
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2690, in resize
    lvm.lvresize(self.vg.name, self._name, self.size)
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 403, in execute
    self.device.resize()
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 310, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 169, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 140, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
LVMError: lvresize failed for 02: running lvm lvresize --force -L 9980m --config  devices { filter=["r|/loop3$|","r|/loop4$|","r|/loop5$|","r|/loop6$|","r|/loop7$|"] }  fedora/02 failed

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19
Comment 1 Emmett Culley 2013-09-18 15:55:27 EDT
Created attachment 799575 [details]
File: anaconda-tb
Comment 2 Emmett Culley 2013-09-18 15:55:31 EDT
Created attachment 799576 [details]
File: anaconda.log
Comment 3 Emmett Culley 2013-09-18 15:55:34 EDT
Created attachment 799577 [details]
File: environ
Comment 4 Emmett Culley 2013-09-18 15:55:38 EDT
Created attachment 799578 [details]
File: lsblk_output
Comment 5 Emmett Culley 2013-09-18 15:55:42 EDT
Created attachment 799579 [details]
File: nmcli_dev_list
Comment 6 Emmett Culley 2013-09-18 15:55:45 EDT
Created attachment 799580 [details]
File: os_info
Comment 7 Emmett Culley 2013-09-18 15:55:49 EDT
Created attachment 799581 [details]
File: program.log
Comment 8 Emmett Culley 2013-09-18 15:55:53 EDT
Created attachment 799582 [details]
File: storage.log
Comment 9 Emmett Culley 2013-09-18 15:55:57 EDT
Created attachment 799583 [details]
File: syslog
Comment 10 Emmett Culley 2013-09-18 15:56:00 EDT
Created attachment 799584 [details]
File: ifcfg.log
Comment 11 Emmett Culley 2013-09-18 15:56:04 EDT
Created attachment 799585 [details]
File: packaging.log
Comment 12 Vratislav Podzimek 2013-09-23 15:04:36 EDT
19:50:02,687 INFO program: Running... lvm lvresize --force -L 9980m --config  devices { filter=["r|/loop3$|","r|/loop4$|","r|/loop5$|","r|/loop6$|","r|/loop7$|"] }  fedora/02
19:50:02,735 INFO program:   New size (2495 extents) matches existing size (2495 extents)
19:50:02,735 INFO program:   Run `lvresize --help' for more information.
19:50:02,736 DEBUG program: Return code: 3

This looks like a blivet issue. Or is anaconda scheduling the resize action even if it shouldn't? Anyway, I think actions like this should be ignored/pruned.
Comment 13 David Lehman 2014-12-02 14:06:57 EST
It looks to me like the anaconda GUI had a bug that clobbered the resized device somehow. Several such issues were fixed for Fedora 20. If you see this bug in Fedora 20 or later, please file a new bug. Thanks.

Note You need to log in before you can comment on or make changes to this bug.