This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 100968 - Status Report e-mail with a system listed twice
Summary: Status Report e-mail with a system listed twice
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Other (Show other bugs)
(Show other bugs)
Version: RHN Stable
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Bret McMillan
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 99024
TreeView+ depends on / blocked
 
Reported: 2003-07-28 06:27 UTC by Patrick C. F. Ernzer
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-26 13:40:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Patrick C. F. Ernzer 2003-07-28 06:27:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Just a minor issue, but still to be cleaned up:

I just got the e-mail below:
[start]
Date:  Mon, 28 Jul 2003 02:02:10 -0400
From: Red Hat Network <dev-null@rhn.redhat.com>
Subject: RHN Daily Status Report for 2003-07-28
[...]
Message-id: <200307280602.h6S62Ao06807@scripts1.back-rdu.redhat.com>
[...]
X-RHN-Login: pcfe
[...]
Systems Not Checking In:
-------------------------
The following systems recently stopped checking in with Red Hat Network:

System Id System Name Last Checkin
1003058416 vmware on morn: RHL 8.0 2003-07-26 20:27:32 (CET)
1003058416 vmware on morn: RHL 8.0 2003-07-26 20:27:32 (CET)
1002391823 vmware: 7.2 buildhost on 2003-07-26 19:20:39 (CET)
[...]
[end]

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. have system not register because it is off (a powered down VMware in this case)
2. have Status Reports switched on
3. receive e-mail

Actual Results:  System 1003058416 is listed twice

Expected Results:  each affected system listed only once

Additional info:

Comment 1 Bret McMillan 2003-08-01 18:39:54 UTC
Hm.  Missed a DISTINCT in the query :/

Fixed in HEAD.

Comment 2 Greg DeKoenigsberg 2003-08-13 21:41:58 UTC
DOCS: None, it's a bugfix.

TEST PLAN: Looks like Patrick's test plan has it covered.

Comment 3 Josef Komenda 2003-08-18 16:50:24 UTC
If I remember correctly, taskomatic is iffy in webdev, so I'll get this in QA. 

Comment 4 Josef Komenda 2003-08-21 22:04:41 UTC
We'll see. 

Comment 5 Josef Komenda 2003-08-26 13:40:59 UTC
Looks good 


Note You need to log in before you can comment on or make changes to this bug.