Bug 1009710 - livemedia-creator need a device pointing to the original live image
livemedia-creator need a device pointing to the original live image
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: dracut-maint
Release Test Team
:
Depends On:
Blocks: 1009711 1016726 1018982
  Show dependency treegraph
 
Reported: 2013-09-18 19:51 EDT by Brian Lane
Modified: 2014-06-17 23:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1016726 (view as bug list)
Environment:
Last Closed: 2014-06-13 05:17:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to add /dev/mapper/live-base (1.38 KB, patch)
2013-09-18 19:52 EDT, Brian Lane
no flags Details | Diff

  None (edit)
Description Brian Lane 2013-09-18 19:51:50 EDT
This is similar to the reason for adding the /run/initramfs/live-baseloop symlink -- access to the original live image without overlays.

livemedia-creator does not create a osmin.img, so there is no mountable device for it to use when rsyncing the live image to the target. It needs a device that points to the original live image without overlays.

Note that lmc won't be creating osmin.img, since really isn't needed any longer. Its purpose was to provide a minimal image that could be dd'd to the target. Now that we use rsync this is no longer necessary.

The included patch adds a /dev/mapper/live-base device that Anaconda can use whether or not there is an osmin present.

This change should also go into F20 and rawhide.
Comment 1 Brian Lane 2013-09-18 19:52:26 EDT
Created attachment 799642 [details]
patch to add /dev/mapper/live-base
Comment 3 Jan Stodola 2014-03-25 08:39:19 EDT
Patch from comment 1 is present in dracut-033-150.el7.

Setting Verified: SanityOnly
Comment 4 Jan Stodola 2014-03-25 10:01:55 EDT
/dev/mapper/live-base exists when booting live media created by lorax-19.6.26-1.el7. The live medium contains dracut-033-150.el7. Installation from the medium using liveinst (anaconda-19.31.70-1.el7) is successful.

Moving to VERIFIED.
Comment 5 Ludek Smid 2014-06-13 05:17:21 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.