Bug 1009741 - hunspell-en includes prebuilt binaries
hunspell-en includes prebuilt binaries
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hunspell-en (Show other bugs)
19
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
: Reopened
: 1022628 (view as bug list)
Depends On:
Blocks: ARM64/F-ExcludeArch-aarch64
  Show dependency treegraph
 
Reported: 2013-09-18 23:25 EDT by D. Marlin
Modified: 2013-11-10 02:16 EST (History)
3 users (show)

See Also:
Fixed In Version: hunspell-en-0.20121024-6.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 02:16:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description D. Marlin 2013-09-18 23:25:18 EDT
Description of problem:

The hunspell-en SRPM includes prebuilt binaries which cause the build to fail on non-x86_64 architectures.

Version-Release number of selected component (if applicable):

hunspell-en-0.20121024-3.fc19

How reproducible:

consistently

Steps to Reproduce:
1.  on a non-x86_64 system (i.e. ARM) 
  mock --rebuild hunspell-en-0.20121024-3.fc19.src.rpm
2.
3.

Actual results:

    :
make -C src deaccent
make[1]: Entering directory `/builddir/build/BUILD/wordlist/scowl/src'
make[1]: `deaccent' is up to date.
make[1]: Leaving directory `/builddir/build/BUILD/wordlist/scowl/src'
./make-aspell-dict
base
deaccent
./make-aspell-dict: line 42: src/deaccent: cannot execute binary file
./make-aspell-dict: line 42: src/deaccent: cannot execute binary file
./make-aspell-dict: line 42: src/deaccent: cannot execute binary file
./make-aspell-dict: line 42: src/deaccent: cannot execute binary file
./make-aspell-dict: line 42: src/deaccent: cannot execute binary file
./make-aspell-dict: line 49: src/deaccent: cannot execute binary file
make: *** [.aspell] Error 126


 /builddir/build/BUILD/wordlist/scowl/src/deaccent: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.32, BuildID[sha1]=0x88474ef56d588823ac2011ee814dade30dad03a8, not stripped

 /builddir/build/BUILD/wordlist/scowl/src/find-accented: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.32, BuildID[sha1]=0x92f252ce61dbf1195f697f46aa883ea54b7e07eb, not stripped


Expected results:

The binaries would be built on the host and the build would complete successfully.


Additional info:

This has already been addressed in F20 and rawhide.
Comment 1 Caolan McNamara 2013-09-19 05:49:29 EDT
I wonder if I managed to stupidly tar up my own local build at one stage rather than a clean tree.
Comment 2 Fedora Update System 2013-09-19 05:57:50 EDT
hunspell-en-0.20121024-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/hunspell-en-0.20121024-5.fc19
Comment 3 Fedora Update System 2013-09-20 12:20:59 EDT
hunspell-en-0.20121024-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Caolan McNamara 2013-10-24 06:31:50 EDT
*** Bug 1022628 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2013-10-24 07:12:47 EDT
hunspell-en-0.20121024-6.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/hunspell-en-0.20121024-6.fc20
Comment 6 Fedora Update System 2013-10-24 13:46:52 EDT
Package hunspell-en-0.20121024-6.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hunspell-en-0.20121024-6.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19851/hunspell-en-0.20121024-6.fc20
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-11-10 02:16:08 EST
hunspell-en-0.20121024-6.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.