Bug 1009857 - Validation: "View all issues" never ends
Validation: "View all issues" never ends
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: CR2
: 6.0.0
Assigned To: Tihomir Surdilovic
Tomas Livora
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 06:27 EDT by Sona Mala
Modified: 2014-08-06 16:03 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Cause: "View all issue" in designer has same behaviour as visual validation, but this feature is not updated. Consequence: If an user corrects some issue than report for each node is not updated and shows deprecated issue. Workaround (if any): 1) correct all issues and click "View all issues" 2) click "Start validation" and "Stop validation" Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:03:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Behaviour for ER4 - video file (7.22 MB, video/webm)
2013-10-15 02:46 EDT, Sona Mala
no flags Details

  None (edit)
Description Sona Mala 2013-09-19 06:27:23 EDT
Description of problem:
If an user uses a feature "View all issues" then it opens editor with all issues. 
If an user closes this editor and he wants to correct the issues then click on affected element opens an editor again.

The problem is that even if the user fix the problem and the issue is obsolete then the editor is shown again.

Version-Release number of selected component (if applicable):
6.0.0 ER3

Steps to Reproduce:
1. create a process (Start -> Script Task)
2. choose "View all issues"
3. close editor
4. activate Script Task
5. close editor
6. set property Script
7. append End Event
8. reactivate Script Task

Actual results:
Step 2: editor which contains "Process has no end node.","Script Task has no script.", "Node has no outgoing connections".
Step 4: editor which contains "Script Task has no script.", "Node has no outgoing connections"
Step 8: editor which contains "Script Task has no script.", "Node has no outgoing connections"

This means that after the issue editor for whole process is closed, there are issues editors for each affected node. (this is nice idea) 

But in actual implementation there missing mechanism how stop this. In the validation menu there is not any option for stops "view all issues". Closing the editor does not stop validation.

Expected results:

Option 1:
---------
Remove features which are fixed. If all issues for that node is corrected then the editor is not shown again.

Step 2: editor which contains "Process has no end node.","Script Task has no script.", "Node has no outgoing connections".
Step 4: editor which contains "Script Task has no script.", "Node has no outgoing connections"
Step 8: editor is not opened

Option 2:
---------
Closing the editor for "View all issues" stops the validation. No editors for each affected node.

Step 2: editor which contains "Process has no end node.","Script Task has no script.", "Node has no outgoing connections".
Step 4: editor is not opened
Step 8: editor is not opened



Option 3:
---------
If user click on "View all issues" then "stop validation" is enabled and "start validation" is disabled. Editor is shown until the user click on "stop validation"

Additional info:
There is small (non-intuitive) workaround for actual state:
   1. click on "start validation"
   2. click on "stop validation"
Comment 1 Tihomir Surdilovic 2013-10-01 20:15:28 EDT
Visual validation once started updates every 3 seconds currently. The editors themselves once opened are for the time that they are opened, so if you fix an issue and click on a node before validation has updated you will still see the issue. 

I think we could add the viewing of validation results to trigger validation before displaying results in addition to the 3 second continuous delay would solve this problem best. WDYT?
Comment 2 Sona Mala 2013-10-03 10:47:18 EDT
That sounds good.

One question: how does the user finish the 3 second continuous delay?

This mean:
  - if the user click on the viewing of validation results button then
       - the editor for all project issues is shown
       - continuous validation is trigger
  - the user closes this editor
  - if the user clicks on the affected node then
       - the editor for node's issues is shown 
  - the user closes this editor
  - if the user fixes some issues and open the editor again then
       - the editor shows the actual issues (if user is not quicker than 3 sec)
    ...
  - the user fix all issues (or not) but definitely he does not want to open any editor for an affected nodes.
       - What should the user do?

The button "Stop validation" will be enabled?
Comment 3 Tihomir Surdilovic 2013-10-08 08:47:04 EDT
every time validation is started the stop validation button is active. is that the question?
Comment 4 Sona Mala 2013-10-15 02:46:51 EDT
Created attachment 812354 [details]
Behaviour for ER4 - video file
Comment 5 Tihomir Surdilovic 2013-11-12 15:37:15 EST
can you let me know if this is still an issue? the stop validation selection is enabled when validation is "on". Does this solve the problem?
Comment 6 Marek Baluch 2013-11-13 03:30:19 EST
I will try to build the latest community bits to see weather the problem is still there or not.

As for the problem itself. The issue is not weather the button is enabled or not. The issue is - if you enable validation and then disable you are still able to view the issues of a node by clicking on it (selecting it). If you do then a popup will show all the issues. This popup should be shown only when validation is enabled but it is shown also when the validation is disabled (if it was previously enabled at least once).
Comment 7 Sona Mala 2013-12-12 08:10:28 EST
The behaviour is still same.

The problem is using just selection "View all issues" selection "Start validation" and "Stop validation" works fine. But if you use "View all issues"
than the validation editor is shown everytime when you activate an invalid node.

Validation message are deprecated if user fix some issues. 

Only way how return original behaviour is select "View all issue" when all issues are fixed or select "Start validation" and "Stop validation". Such behaviour is not intuitive.


I think that this selection should show all issues in the process and it does not propagate them on nodes (click on node does not show the validation editor).


Please tell me if the "View all issues" is supposed to be used separately or this selection should be visible only if the validation is ON.
Comment 8 Tihomir Surdilovic 2013-12-13 18:00:17 EST
View all issue should always be present, regardless if validation is on/off.
Comment 9 Tihomir Surdilovic 2013-12-16 11:15:08 EST
A bad cut/paste for another BZ causes the View all issues option to never be enabled. This is now fixed in designer master and 6.0.x branches.
Comment 10 Kris Verlaenen 2013-12-18 09:30:00 EST
If I have a process with just a start node and click view all issues, it shows two errors in a popup (as expected).  If I then close the dialog and click on the start node however, it shows a similar dialog again (note that compared to start validation, it is showing the same dialog, just not annotating the node with a red border).  View all issues should not trigger this dialog to be shown when clicking nodes (it should only show the first dialog of all issues).

When clicking on start validation however, the behavior is as expected, it marks the start node with a red border and if I click on it, it shows the popup.  If I click stop validating, it stops this behavior (as expected).
Comment 11 Tihomir Surdilovic 2013-12-18 10:58:37 EST
updated to disable validation on view all issues. this should eliminate the issue above. fix in designer master and 6.0.x branches.
Comment 12 Tomas Livora 2014-01-10 03:49:06 EST
The bug is not fixed in ER7.

When you create a new process which contains only a start node, click on the 'View all issues' option, close the dialog and click on the start node, the 'Validation Suggestions' dialog will be shown even though the validation has not been started. This happens only if you open the dialog with all issues right before clicking on a node. If you start and stop validation and then click on the node again no dialog will be shown.
Comment 14 Sona Mala 2014-01-30 05:22:41 EST
I can not reproduce this issue for CR2.
It seems that CR2 contains expected behaviour for this issue. 
Please, do you know about it?


Actual behaviour for CR2:
  - no pop up window when an user activate element.
Comment 16 Kris Verlaenen 2014-02-03 10:22:40 EST
Verified this indeed works on CR2, will set to ON_QA so they can close it as verified.

Note You need to log in before you can comment on or make changes to this bug.