Bug 100987 - Kernel panic after trying to boot into kernel-2.6.0-0.test1.1.26
Kernel panic after trying to boot into kernel-2.6.0-0.test1.1.26
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-28 08:36 EDT by Alan Sanderson
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-13 09:39:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Sanderson 2003-07-28 08:36:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4) Gecko/20030703

Description of problem:
After installing kernel-2.6.0-0.test1.1.26, upon rebooting the system a kernel
panic happens and the following message is displayed
'Kernel panic: No init found, Try passing init= option to kernel.'

Version-Release number of selected component (if applicable):
kernel-2.6.0-0.test1.1.26

How reproducible:
Always

Steps to Reproduce:
1.RPM -ivh kernel-2.6.0-0.test1.1.26.i586.rpm
2.reboot system
3.select kernel-2.6.0-0.test1.1.26 from grub
4.Kernel panic
    

Actual Results:  Kernel panic: No init found, Try passing init= option to kernel.

Expected Results:  System boots 

Additional info:

Linux k6-2-500-rhl9 2.4.20-19.9 #1 Tue Jul 15 17:03:15 EDT 2003 i586 i586 i386
GNU/Linux
Comment 1 Bill Nottingham 2003-07-28 17:37:01 EDT
Are you using LVM?
Comment 2 Alan Sanderson 2003-07-29 01:18:52 EDT
LVM? Logical Volume Management, if that's what it LVM is, I'm not using it.
Comment 3 Alan Sanderson 2003-07-29 01:19:59 EDT
I am using ReiserFS though.
Comment 4 Alan Sanderson 2003-07-31 21:16:18 EDT
I just installed kernel-2.6.0-0.test2.1.28.i586.rpm with the same results. This
time I noticed a few more messages before when it says 'kernel panic ...'
Firstly after issuing rpm -ivh kernel-2.6.0-0.test2.1.28.i586.rpm the message
'WARNING: /lib/modules/2.6.0-0.test2.1.28/kernel/drivers/char/agp/nvidia-agp.ko
needs unknown symbol agp_memory_reserved'. Don't know if that is of any
consequence, but it does it anyway.
So I reboot seeing if it will get into kernel-2.6.0-0.test2 this time and then
the following error message appeared at the just before the kernel panic 
"Mounting root filesystem
mount: error 19 mounting reiserfs
pivotroot: pivot_root (/sysroot,/sysroot/initrd) failed: 2
umount /initrd/proc failed: 2
freeing unused kernel memory: 144k freed"
then finally as previously found with the kernel-2.6.0-0.test1.1.26 kernel
'kernel panic : No init found. Try passing init= option to kernel'
So it looks like the kernel is having a problem with reiserFS.
Comment 5 Arjan van de Ven 2003-08-01 03:56:33 EDT
Have you installed the kernel-unsupported rpm as well ?
Comment 6 Alan Sanderson 2003-08-01 11:35:20 EDT
No I have not I will, I was not aware that was required (from reading the
readme.txt file in the kernel directories on
http://people.redhat.com/arjanv/2.5/RPMS.kernel). I will give that a try as soon
as I finish compiling glibc (old amd-k6-500 based box so it'll probably go
overnight (1:32am Saturday over here atm) so i'll try it when I wake up) and
will let you know.
Comment 7 Alan Sanderson 2003-08-02 00:30:54 EDT
Yep that did the trick.
I don't know if it is of any concern but will installing the following messages
were passed to the console:
rpm -ivh kernel-2.6.0-0.test2.1.28.i586.rpm
kernel-source-2.6.0-0.test2.1.28.i386.rpm
kernel-unsupported-2.6.0-0.test2.1.28.i586.rpm
warning: kernel-2.6.0-0.test2.1.28.i586.rpm: V3 DSA signature: NOKEY, key ID
9d6b4012
Preparing...                ########################################### [100%]
   1:kernel-unsupported     ########################################### [ 33%]
   2:kernel                 ########################################### [ 67%]
WARNING:
/lib/modules/2.6.0-0.test2.1.28/unsupported/drivers/video/matrox/matroxfb_crtc2.ko
needs unknown symbol matroxfb_enable_irq
WARNING:
/lib/modules/2.6.0-0.test2.1.28/unsupported/drivers/isdn/hardware/eicon/divacapi.ko
needs unknown symbol application
WARNING:
/lib/modules/2.6.0-0.test2.1.28/unsupported/drivers/isdn/hardware/eicon/divacapi.ko
needs unknown symbol adapter
WARNING:
/lib/modules/2.6.0-0.test2.1.28/unsupported/drivers/isdn/hardware/eicon/divacapi.ko
needs unknown symbol MapController
WARNING:
/lib/modules/2.6.0-0.test2.1.28/unsupported/drivers/isdn/hardware/eicon/divacapi.ko
needs unknown symbol max_adapter
WARNING: /lib/modules/2.6.0-0.test2.1.28/unsupported/drivers/char/istallion.ko
needs unknown symbol schedule_task
WARNING:
/lib/modules/2.6.0-0.test2.1.28/unsupported/drivers/char/generic_serial.ko needs
unknown symbol cli
WARNING:
/lib/modules/2.6.0-0.test2.1.28/unsupported/drivers/char/generic_serial.ko needs
unknown symbol restore_flags
WARNING:
/lib/modules/2.6.0-0.test2.1.28/unsupported/drivers/char/generic_serial.ko needs
unknown symbol save_flags
WARNING:
/lib/modules/2.6.0-0.test2.1.28/unsupported/drivers/char/generic_serial.ko needs
unknown symbol sti
WARNING: /lib/modules/2.6.0-0.test2.1.28/unsupported/drivers/char/epca.ko needs
unknown symbol cli
WARNING: /lib/modules/2.6.0-0.test2.1.28/unsupported/drivers/char/epca.ko needs
unknown symbol restore_flags
WARNING: /lib/modules/2.6.0-0.test2.1.28/unsupported/drivers/char/epca.ko needs
unknown symbol save_flags
WARNING: /lib/modules/2.6.0-0.test2.1.28/unsupported/drivers/char/stallion.ko
needs unknown symbol schedule_task
WARNING: /lib/modules/2.6.0-0.test2.1.28/kernel/drivers/char/agp/nvidia-agp.ko
needs unknown symbol agp_memory_reserved
   3:kernel-source          ########################################### [100%]

Dispite those messages shown at installation time the kernel still booted and X
came up no problem.

Note You need to log in before you can comment on or make changes to this bug.