Bug 1009881 - rhc / IDE plugin / wizard support for multiple OpenShift Environments
rhc / IDE plugin / wizard support for multiple OpenShift Environments
Status: CLOSED DUPLICATE of bug 1006068
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
2.2.0
x86_64 Unspecified
low Severity medium
: ---
: ---
Assigned To: jofernan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 08:12 EDT by Arthur Enright
Modified: 2016-05-25 09:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-08 09:44:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arthur Enright 2013-09-19 08:12:37 EDT
Description of problem: rhc tools / IDE plugins / rhc wizard does not understand being connected to multiple OpenStack environments (like both On-line and Enterprise or multiple Enterprise instances)  Improvements to the wizard to make allowances for this would be desirable.  A documentation BZ was also openend for the interim: BZ 1009869


Version-Release number of selected component (if applicable): Enterprise 1.2 / Currnet On-line


How reproducible: 100%


Steps to Reproduce:
1. Configure rhc / IDE plugin for On-line
2. Try to connect to Enterprise
3. Neat errors

Actual results: You have to throw away your rhc config and re-run the wizard / re-configure by hand in for each OpenShift environment you wish to use


Expected results: It would be nice to have the wizard aware of multiple OpenShift environments and have a supporting dialog.


Additional info: Case 00930509 can be referenced.
Comment 2 Brenton Leanhardt 2014-08-08 09:44:37 EDT
'rhc server' support has existed upstream in the rhc gem for a few months now.  We're planning to merge this functionality in to the OpenShift Enterprise rhc RPM for the upcoming minor release.

*** This bug has been marked as a duplicate of bug 1006068 ***
Comment 3 Brenton Leanhardt 2014-08-08 09:45:24 EDT
It's also my understanding that the JBoss Developer suite OpenShift plugin allows the user to configure multiple accounts.

Note You need to log in before you can comment on or make changes to this bug.