Bug 1009916 - Post processing error: Could not reserve enough space for object heap (32bit windows)
Summary: Post processing error: Could not reserve enough space for object heap (32bit ...
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer
Version: 6.0.0
Hardware: Unspecified
OS: Windows
urgent
urgent
Target Milestone: ER4
: 6.0.0
Assignee: Thomas Hauser
QA Contact: Len DiMaggio
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-09-19 13:35 UTC by Pavol Srna
Modified: 2014-10-08 15:21 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-26 13:35:14 UTC
Type: Bug


Attachments (Terms of Use)
screenshot (137.06 KB, image/png)
2013-09-19 13:35 UTC, Pavol Srna
no flags Details
screenshot-2 (87.17 KB, image/png)
2013-09-19 15:48 UTC, Pavol Srna
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 956281 None None None Never

Description Pavol Srna 2013-09-19 13:35:30 UTC
Created attachment 799949 [details]
screenshot

Description of problem:

Please see screenshot attached.


How reproducible: not known, occurs rarely

Comment 1 Pavol Srna 2013-09-19 13:37:56 UTC
Java(TM) SE Runtime Environment (build 1.7.0_25-b17)

Comment 2 Thomas Hauser 2013-09-19 13:41:20 UTC
This issue seems to be occuring with the installer tries to launch the server. The server is started as a separate Process, in its own JVM. I have not been able to reproduce this issue. I would see if you can reproduce the issue by launching the server outside of the installer (the installer just invokes ./standalone.sh --admin-only or ./domain.sh --admin-only). 

It would be helpful to know which job exactly is causing this error (the number in the parenthesis on that panel.)

Comment 4 Pavol Srna 2013-09-19 15:47:44 UTC
You are right Thomas, I cannot launch the server outside of the installer.

Comment 5 Pavol Srna 2013-09-19 15:48:19 UTC
Created attachment 800016 [details]
screenshot-2

Attached screenshot-2.

Comment 6 Pavol Srna 2013-09-20 08:55:26 UTC
The issue here is java and 32bit windows and that there is not enough *contiguous* memory for object heap.

oracle.com says:

"The maximum theoretical heap limit for the 32-bit JVM is 4G. Due to various additional constraints such as available swap, kernel address space usage, memory fragmentation, and VM overhead, in practice the limit can be much lower. On most modern 32-bit Windows systems the maximum heap size will range from 1.4G to 1.6G."

And that is not enough for launching the server inside the installer.

We *do* support x86 architecture on windows. How can we fix this?

Comment 7 Thomas Hauser 2013-09-20 13:03:58 UTC
From your screenshots above, not only is it not enough to launch the server from inside the installer, but it's not enough to launch the server even from outside of it as well.

Comment 8 Pavol Srna 2013-09-20 13:20:48 UTC
I tried today again. There were 1.7GB Free and 2.7GB Available memory according to the windows task manager utility. I was able to run './standalone.bat --admin-only' from within the console. But the installer itself has failed.


Note You need to log in before you can comment on or make changes to this bug.