Bug 1009939 - goa-daemon runs to 100% CPU
goa-daemon runs to 100% CPU
Status: CLOSED DUPLICATE of bug 1006204
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-online-accounts (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Debarshi Ray
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 10:14 EDT by Matěj Cepl
Modified: 2013-09-19 10:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-19 10:18:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2013-09-19 10:14:20 EDT
Description of problem:
And this is the backtrace

Loaded symbols for /lib64/libutil.so.1
0x00007fd3981291ed in write () at ../sysdeps/unix/syscall-template.S:81
81	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
Traceback (most recent call last):
  File "/usr/share/gdb/auto-load/usr/lib64/libgobject-2.0.so.0.3600.3-gdb.py", line 9, in <module>
    from gobject import register
  File "/usr/share/glib-2.0/gdb/gobject.py", line 3, in <module>
    import gdb.backtrace
ImportError: No module named backtrace
Missing separate debuginfos, use: debuginfo-install at-spi2-atk-2.8.1-1.el7.x86_64 at-spi2-core-2.8.0-3.el7.x86_64 dbus-glib-0.100-4.el7.x86_64 dbus-libs-1.6.12-5.el7.x86_64 enchant-1.6.0-6.el7.x86_64 expat-2.1.0-6.el7.x86_64 fontconfig-2.10.95-3.el7.x86_64 freetype-2.4.11-6.el7.x86_64 geoclue-0.12.99-5.el7.x86_64 graphite2-devel-1.2.2-3.el7.x86_64 gstreamer1-1.0.7-1.el7.x86_64 gstreamer1-plugins-base-1.0.7-2.el7.x86_64 gvfs-1.16.3-2.el7.x86_64 harfbuzz-0.9.20-1.el7.x86_64 harfbuzz-icu-0.9.20-1.el7.x86_64 keyutils-libs-1.5.6-1.el7.x86_64 krb5-libs-1.11.3-9.el7.x86_64 libXau-1.0.8-1.el7.x86_64 libXcomposite-0.4.4-3.el7.x86_64 libXcursor-1.1.14-1.el7.x86_64 libXdamage-1.1.4-3.el7.x86_64 libXext-1.3.2-1.el7.x86_64 libXfixes-5.0.1-1.el7.x86_64 libXi-1.7.2-1.el7.x86_64 libXinerama-1.1.3-1.el7.x86_64 libXrandr-1.4.1-1.el7.x86_64 libXrender-0.9.8-1.el7.x86_64 libXxf86vm-1.1.3-1.el7.x86_64 libbluray-0.2.3-3.el7.x86_64 libdrm-2.4.46-1.el7.x86_64 libffi-3.0.13-7.el7.x86_64 libgcc-4.8.1-8.el7.x86_64 libgcrypt-1.5.3-1.el7.x86_64 libgpg-error-1.12-1.el7.x86_64 libicu-50.1.2-5.el7.x86_64 libjpeg-turbo-1.2.90-2.el7.x86_64 libpng-1.5.13-2.el7.x86_64 libstdc++-4.8.1-8.el7.x86_64 libuuid-2.23.2-5.el7.x86_64 libwebp-0.3.0-1.el7.x86_64 libxcb-1.9-3.el7.x86_64 libxslt-1.1.28-3.el7.x86_64 mesa-libEGL-9.2-1.20130902.el7.x86_64 mesa-libGL-9.2-1.20130902.el7.x86_64 mesa-libgbm-9.2-1.20130902.el7.x86_64 mesa-libglapi-9.2-1.20130902.el7.x86_64 nss-softokn-freebl-3.15.1-2.el7.x86_64 orc-0.4.17-2.el7.x86_64 pcre-8.32-7.el7.x86_64 pixman-0.30.0-1.el7.x86_64 sqlite-3.7.17-1.el7.x86_64 systemd-libs-206-8.el7.x86_64 xz-libs-5.1.2-5alpha.el7.x86_64 zlib-1.2.7-10.el7.x86_64
(gdb) 
(gdb) thread apply all backtrace

Thread 4 (Thread 0x7fd38b522700 (LWP 1938)):
#0  0x00007fd397e45b0d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fd39837f0f4 in g_main_context_poll (priority=2147483647, n_fds=1, 
    fds=0x7fd3840008c0, timeout=-1, context=0x1b22680) at gmain.c:3995
#2  g_main_context_iterate (context=context@entry=0x1b22680, block=block@entry=1, 
    dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3696
#3  0x00007fd39837f1fc in g_main_context_iteration (context=0x1b22680, 
    may_block=may_block@entry=1) at gmain.c:3762
#4  0x00007fd39837f249 in glib_worker_main (data=<optimized out>) at gmain.c:5427
#5  0x00007fd3983a3185 in g_thread_proxy (data=0x1b23000) at gthread.c:798
#6  0x00007fd398122de3 in start_thread (arg=0x7fd38b522700) at pthread_create.c:308
#7  0x00007fd397e500dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7fd38ad21700 (LWP 1939)):
#0  pthread_cond_wait@@GLIBC_2.3.2 ()
    at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fd3983be4c7 in g_cond_wait (cond=cond@entry=0x1b268a8, 
    mutex=mutex@entry=0x1b268a0) at gthread-posix.c:750
#2  0x00007fd398355b0b in g_async_queue_pop_intern_unlocked (queue=queue@entry=0x1b268a0, 
    wait=wait@entry=1, end_time=end_time@entry=-1) at gasyncqueue.c:421
#3  0x00007fd398355f07 in g_async_queue_pop (queue=queue@entry=0x1b268a0)
    at gasyncqueue.c:455
#4  0x00000000004117e8 in on_job_scheduled (job=0x1b27d80, cancellable=0x1b490f0, 
    self=<optimized out>) at goakerberosidentitymanager.c:968
#5  0x00007fd398b2c806 in io_job_thread (task=<optimized out>, 
    source_object=<optimized out>, task_data=0x1b27d80, cancellable=<optimized out>)
    at gioscheduler.c:89
#6  0x00007fd398b4b0a5 in g_task_thread_pool_thread (thread_data=0x1b2b2a0, 
    pool_data=<optimized out>) at gtask.c:1242
#7  0x00007fd3983a3b46 in g_thread_pool_thread_proxy (data=<optimized out>)
    at gthreadpool.c:309
#8  0x00007fd3983a3185 in g_thread_proxy (data=0x1b23190) at gthread.c:798
#9  0x00007fd398122de3 in start_thread (arg=0x7fd38ad21700) at pthread_create.c:308
#10 0x00007fd397e500dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7fd38a520700 (LWP 1940)):
#0  0x00007fd397e45b0d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fd39837f0f4 in g_main_context_poll (priority=2147483647, n_fds=3, 
    fds=0x7fd3800010c0, timeout=-1, context=0x7fd37c00d9a0) at gmain.c:3995
#2  g_main_context_iterate (context=0x7fd37c00d9a0, block=block@entry=1, 
    dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3696
#3  0x00007fd39837f55a in g_main_loop_run (loop=0x7fd37c00d930) at gmain.c:3895
#4  0x00007fd398b99d46 in gdbus_shared_thread_func (user_data=0x7fd37c00d970)
    at gdbusprivate.c:278
#5  0x00007fd3983a3185 in g_thread_proxy (data=0x7fd37c004b70) at gthread.c:798
#6  0x00007fd398122de3 in start_thread (arg=0x7fd38a520700) at pthread_create.c:308
#7  0x00007fd397e500dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7fd39eefda40 (LWP 1923)):
#0  0x00007fd3981291ed in write () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fd3983bd5af in g_wakeup_signal (wakeup=0x1b1d330) at gwakeup.c:238
#2  0x00007fd39837bd0e in g_main_context_add_poll_unlocked (context=<optimized out>, 
---Type <return> to continue, or q <return> to quit---
    priority=<optimized out>, fd=<optimized out>) at gmain.c:4122
#3  0x00007fd39837bd90 in unblock_source (source=source@entry=0x7fd37c137340) at gmain.c:2975
#4  0x00007fd39837ef88 in g_main_dispatch (context=0x1b22550) at gmain.c:3070
#5  g_main_context_dispatch (context=context@entry=0x1b22550) at gmain.c:3630
#6  0x00007fd39837f158 in g_main_context_iterate (context=0x1b22550, block=block@entry=1, 
    dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3701
#7  0x00007fd39837f55a in g_main_loop_run (loop=0x1b21d90) at gmain.c:3895
#8  0x00000000004086e2 in main (argc=1, argv=0x7fffe2222038) at main.c:135
(gdb) 



Version-Release number of selected component (if applicable):
gnome-online-accounts-3.8.3-1.el7.x86_64

How reproducible:
happens from time to time
not sure how to reproduce it
Comment 1 Vladimir Benes 2013-09-19 10:18:22 EDT
anyway, I think it's now fixed. It's problem with handling kerberos tickets.

*** This bug has been marked as a duplicate of bug 1006204 ***

Note You need to log in before you can comment on or make changes to this bug.