This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1009962 - Undo operation is not considered to be a modification by the process designer.
Undo operation is not considered to be a modification by the process designer.
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity low
: ER5
: 6.0.0
Assigned To: Tihomir Surdilovic
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 11:16 EDT by Marek Baluch
Modified: 2014-08-06 16:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:10:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
How to reproduce vid. (338.85 KB, video/webm)
2013-09-19 11:16 EDT, Marek Baluch
no flags Details

  None (edit)
Description Marek Baluch 2013-09-19 11:16:54 EDT
Created attachment 800011 [details]
How to reproduce vid.

Description of problem:
Undo operation is not considered as modification by the process designer. It is possible to get around the problem by clicking the canvas.

Steps to Reproduce:
See attached video.

Found on:
BPMS 6.0.0.ER3.
Comment 1 Tihomir Surdilovic 2013-11-01 16:54:11 EDT
Not sure I understand the issue as described. Designer supports CTRL-Z as undo operation.
Comment 2 Marek Baluch 2013-11-03 04:32:55 EST
I have a process in which I delete the 'start' node. I save the process. Then I return the deleted 'start' node using the 'undo' button in the toolbar. At this point the process has changed because the 'start' node is there again right?
When I try to save the process I get the message 'Process contains no changes since last save'.

Please see the attached video. It demonstrates the problem.

I hope this helps.
Comment 3 Tihomir Surdilovic 2013-11-04 10:34:14 EST
The undo and redo operations now set the unsaved flag in Designer.
Comment 4 Marek Baluch 2013-11-23 09:13:06 EST
Verified on ER5.

Note You need to log in before you can comment on or make changes to this bug.