Bug 1010017 - Anaconda crashes manipulating custom partitions and just generally misbehaves
Anaconda crashes manipulating custom partitions and just generally misbehaves
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
All All
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 13:28 EDT by Rick Graham
Modified: 2014-09-16 09:33 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-11 10:15:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick Graham 2013-09-19 13:28:24 EDT
Description of problem:

Trying to install on a 1/2T Passport USB3 from a Fedora 19 DVD.

In short I can't:
   - create a custom install target partitions
   - assume a preconfigured install target partitioning
   - delete existing install target partition maps

All of these options lead to completely erroneous error messages and crashes...


Anadonda (19-30.13.1) refuses to let me use custom partitioning.  I tried two approaches, using the interface to create custom partitioning and pre partitioning the disk on another linux box.

In both cases, I have swap, boot, root(/) and home created and assigned as target partitions, anaconda then complains that there is no room to install.

 ----

Your current Fedora software selection requires 6.74 gigabytes of available space including 2.89
GB for software and ....blah blah

 ----

I've told it to reformat, but there is still a preserve flag on it that crashed anaconda when I try to remove it.  Anaconda Crashes when I delete all partitions on the drive and try to recreate the partition table. (2x)

Installing on a usb3 drive on a Mac Air.  Sorry, I don't have the confidence in this installer to let it do what it wants, and it refuses to do what I want.

This is a showstopper for installing fedora 19 in this way.  It appears to be a my way or the highway thing.

(Also no wireless because if incomplete connection interface, but this has been deemed not a bug)


How reproducible:

Try to create a custom partition table (non LVM) in a usb3 drive (WD Passport 1/2T) and install to it.  Anaconda says there is no room in spite of having a partition table that looks like this:

/home 363GB sdb4
swap 4GB sdb2
/boot 10GB sdb1
/ 100GB sdb3 (insists on reformat, although it is clean, still, no joy)

Manipulation of the partitioning leads to crashes.
Comment 1 David Shea 2013-09-19 13:35:12 EDT
Please attach the traceback file from the crash along with any other log files that are in /tmp
Comment 2 Rick Graham 2013-09-19 15:05:34 EDT
I'm installing from a USB DVD to a USB3 drive with a Mac Air in the middle.

Is there a way to configure this so I have a /tmp I can read after a crash?
Comment 3 David Shea 2013-09-19 15:08:46 EDT
You can switch to a virtual terminal after the crash by hitting Ctrl+Alt+F2, or you can use the exception dialog to report a bug with the log files attached.
Comment 4 David Lehman 2013-09-19 17:29:18 EDT
Please read through the storage portion of the installation guide:

  http://docs.fedoraproject.org/en-US/Fedora/19/html/Installation_Guide/s1-diskpartsetup-x86.html
Comment 5 Rick Graham 2014-09-16 09:33:04 EDT
I can't supply the data requested.

Note You need to log in before you can comment on or make changes to this bug.