Bug 1010022 - Organizations "environment" pane raise to foreground after creating new env, blocks menu access.
Organizations "environment" pane raise to foreground after creating new env, ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Walden Raines
Og Maciel
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-19 13:57 EDT by Corey Welton
Modified: 2014-04-24 13:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:08:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2013-09-19 13:57:07 EDT
Description of problem:
Upon creation of a new environment for an org (and only after creating, it doesn't seem to happen beforehand), the right pane with the environment list is raised to the foreground, causing menus to load behind it and usually leave portions of them inaccessible.

Version-Release number of selected component (if applicable):

Satellite-6.0.2-RHEL-6-20130919.0


How reproducible:


Steps to Reproduce:
1.  Navigate to Administer > Organizations > ACME_Corporation 
2.  Hover nav (but do not click) Content > Sync Management > Sync Overview; assure that the menu stays atop all other UI elements
3.  In the environment view for ACME_Corporation, "Add New Environment", and create a new environment, 'foobar'
4.  Repeat step #2; view results
5.  Attempt to hover nav to Content > Content View Definitions view results
Actual results:

In step 4, It is evident that menu gets hidden behind the environment view
In step 5, user is unable to nav down to Content View Definitions because the menu disappears.


Expected results:
Menu stays in forefront; adding a new environment does not move this pane to foreground. 

Additional info:
Comment 2 Walden Raines 2013-09-25 15:08:08 EDT
PR: https://github.com/Katello/katello/pull/3036
Comment 3 Walden Raines 2013-09-25 15:34:55 EDT
commit d6c8d2bbe4d03288dd7effe1214aa7f7171d2b93
Merge: ea4de33 8fd82fa
Author: Walden Raines <walden@redhat.com>
Date:   Wed Sep 25 12:34:18 2013 -0700

    Merge pull request #3036 from waldenraines/bug-1012105
    
    Bugs #1012105 and #1010022: ensure menu is on top of panel.

commit 8fd82fa388baad9ba95a7ad3045a0e40c285f4a6
Author: Walden Raines <walden@redhat.com>
Date:   Wed Sep 25 15:03:57 2013 -0400

    Bugs #1012105 and #1010022: ensure menu is on top of panel.
Comment 7 Og Maciel 2013-10-17 17:08:00 EDT
Verified:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.25-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.25-1.el6sam.noarch
* candlepin-tomcat6-0.8.25-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.3.0-18.el6sat.noarch
* foreman-compute-1.3.0-18.el6sat.noarch
* foreman-libvirt-1.3.0-18.el6sat.noarch
* foreman-postgresql-1.3.0-18.el6sat.noarch
* foreman-proxy-1.3.0-3.el6sat.noarch
* katello-1.4.6-39.el6sat.noarch
* katello-all-1.4.6-39.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.4-1.el6sat.noarch
* katello-cli-1.4.3-24.el6sat.noarch
* katello-cli-common-1.4.3-24.el6sat.noarch
* katello-common-1.4.6-39.el6sat.noarch
* katello-configure-1.4.7-5.el6sat.noarch
* katello-configure-foreman-1.4.7-5.el6sat.noarch
* katello-configure-foreman-proxy-1.4.7-5.el6sat.noarch
* katello-foreman-all-1.4.6-39.el6sat.noarch
* katello-glue-candlepin-1.4.6-39.el6sat.noarch
* katello-glue-elasticsearch-1.4.6-39.el6sat.noarch
* katello-glue-pulp-1.4.6-39.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.4-4.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-katello-plugins-0.2-1.el6sat.noarch
* pulp-nodes-common-2.3.0-0.22.beta.el6sat.noarch
* pulp-nodes-parent-2.3.0-0.22.beta.el6sat.noarch
* pulp-puppet-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-rpm-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-selinux-2.3.0-0.22.beta.el6sat.noarch
* pulp-server-2.3.0-0.22.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.0.7-1.el6sat.noarch
* signo-0.0.22-2.el6sat.noarch
* signo-katello-0.0.22-2.el6sat.noarch
Comment 8 Bryan Kearney 2014-04-24 13:08:31 EDT
This was verified and delivered with MDP2. Closing it out.

Note You need to log in before you can comment on or make changes to this bug.