Bug 1010204 - skipped count is not available in XML output of rebalance status
skipped count is not available in XML output of rebalance status
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
unspecified
Unspecified Unspecified
high Severity medium
: ---
: RHGS 2.1.2
Assigned To: Kaushal
shylesh
: ZStream
Depends On:
Blocks: 1012772
  Show dependency treegraph
 
Reported: 2013-09-20 04:44 EDT by Aravinda VK
Modified: 2015-05-13 12:27 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.44.1u2rhs
Doc Type: Bug Fix
Doc Text:
Previously, the XML output of Rebalance status did not contain the Rebalance skipped count statistic. With this fix, a new tag <skipped> is introduced in the XML output to indicate the number of skipped files.
Story Points: ---
Clone Of:
: 1012772 (view as bug list)
Environment:
Last Closed: 2014-02-25 02:39:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aravinda VK 2013-09-20 04:44:00 EDT
Description of problem:

XML tag "skipped" is not available in xml output of gluster rebalance status


How reproducible:
100%

Steps to Reproduce:
1. gluster volume rebalance <VOLNAME> status
2. and run gluster volume rebalance <VOLNAME> status --xml
3. Skipped files count available in first run which is not available in 2nd step(xml output)

Actual results:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<cliOutput>
  <opRet>0</opRet>
  <opErrno>0</opErrno>
  <opErrstr/>
  <volRebalance>
    <op>3</op>
    <nodeCount>1</nodeCount>
    <node>
      <nodeName>localhost</nodeName>
      <files>0</files>
      <size>0</size>
      <lookups>0</lookups>
      <failures>0</failures>
      <status>0</status>
      <statusStr>completed</statusStr>
    </node>
    <aggregate>
      <files>0</files>
      <size>0</size>
      <lookups>0</lookups>
      <failures>0</failures>
      <status>0</status>
      <statusStr>completed</statusStr>
    </aggregate>
  </volRebalance>
</cliOutput>


Expected results:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<cliOutput>
  <opRet>0</opRet>
  <opErrno>0</opErrno>
  <opErrstr/>
  <volRebalance>
    <op>3</op>
    <nodeCount>1</nodeCount>
    <node>
      <nodeName>localhost</nodeName>
      <files>0</files>
      <size>0</size>
      <lookups>0</lookups>
      <failures>0</failures>
      <skipped>0</skipped>
      <status>0</status>
      <statusStr>completed</statusStr>
    </node>
    <aggregate>
      <files>0</files>
      <size>0</size>
      <lookups>0</lookups>
      <failures>0</failures>
      <skipped>0</skipped>
      <status>0</status>
      <statusStr>completed</statusStr>
    </aggregate>
  </volRebalance>
</cliOutput>


Additional info:
Comment 2 Amar Tumballi 2013-10-04 02:50:23 EDT
https://code.engineering.redhat.com/gerrit/#/c/13656
Comment 3 shylesh 2013-12-11 23:26:41 EST
Now "skipped" field appers in xml.  verified on 
3.4.0.44.1u2rhs-1.el6rhs.x86_64
<files>281</files>
      <size>147324928</size>
      <lookups>966</lookups>
      <failures>0</failures>
      <skipped>0</skipped>
      <status>3</status>
      <statusStr>completed</statusStr>
      <runtime>50.00</runtime>
    </node>
    <node>
      <nodeName>rhs-client9.lab.eng.blr.redhat.com</nodeName>
      <id>200a73a8-56f6-4f52-85db-1914c52da35a</id>
      <files>149</files>
      <size>78118912</size>
      <lookups>851</lookups>
      <failures>0</failures>
      <skipped>26</skipped>
      <status>3</status>
      <statusStr>completed</statusStr>
      <runtime>44.00</runtime>
    </node>
    <node>
      <nodeName>rhs-client39.lab.eng.blr.redhat.com</nodeName>
      <id>ebe5adcb-0e20-4514-bb8c-a7bde98f5cb2</id>
      <files>75</files>
      <size>39321600</size>
      <lookups>848</lookups>
      <failures>0</failures>
      <skipped>88</skipped>
      <status>3</status>
      <statusStr>completed</statusStr>
      <runtime>40.00</runtime>
    </node>
    <aggregate>
      <files>505</files>
      <size>264765440</size>
      <lookups>2665</lookups>
      <failures>0</failures>
      <skipped>114</skipped>
      <status>3</status>
      <statusStr>completed</statusStr>
      <runtime>50.00</runtime>
    </aggregate>
  </volRebalance>
</cliOutput>
Comment 4 Pavithra 2014-01-16 00:55:21 EST
Kaushal,

Can you please verify the doc text for technical accuracy?
Comment 5 Kaushal 2014-01-16 06:01:41 EST
Doc text looks fine.
Comment 7 errata-xmlrpc 2014-02-25 02:39:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.