Bug 1010217 - AVC found during python/mysql testing
AVC found during python/mysql testing
Status: CLOSED DUPLICATE of bug 1009449
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.5
All Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-20 05:24 EDT by Branislav Náter
Modified: 2013-09-23 03:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 03:58:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Branislav Náter 2013-09-20 05:24:40 EDT
AVC found during testing python mysql db connector.

Version-Release number of selected component (if applicable):
RHEL6.5-20130913.0
selinux-policy-3.7.19-216.el6.noarch

Steps to Reproduce: 
run /CoreOS/MySQL-python/Sanity/basic test


Actual results: 
time->Wed Sep 18 15:27:42 2013
type=SYSCALL msg=audit(1379532462.532:35): arch=c000003e syscall=2 success=no exit=-13 a0=7f0624409084 a1=0 a2=1b6 a3=0 items=0 ppid=28960 pid=28986 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="my_print_defaul" exe="/usr/bin/my_print_defaults" subj=unconfined_u:system_r:mysqld_safe_t:s0 key=(null)
type=AVC msg=audit(1379532462.532:35): avc:  denied  { read } for  pid=28986 comm="my_print_defaul" name="urandom" dev=devtmpfs ino=3877 scontext=unconfined_u:system_r:mysqld_safe_t:s0 tcontext=system_u:object_r:urandom_device_t:s0 tclass=chr_file

full log: http://beaker-archive.app.eng.bos.redhat.com/beaker-logs/2013/09/4993/499325/1050119/15749096/79675042/test_log-Setup-avc.log

Expected results:
no AVC
Comment 2 Karel Volný 2013-09-23 03:58:42 EDT

*** This bug has been marked as a duplicate of bug 1009449 ***

Note You need to log in before you can comment on or make changes to this bug.