Bug 1010219 - Option to start business central with example setup
Option to start business central with example setup
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER5
: 6.0.0
Assigned To: Maciej Swiderski
Tomas Livora
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-20 05:53 EDT by Maciej Swiderski
Modified: 2014-08-06 16:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:12:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maciej Swiderski 2013-09-20 05:53:52 EDT
Description of problem:
As an alternative setup to the playground repositories that are loaded on startup allow to create an example configuration that provides quick and easy start to work on new projects. 
An example configuration consists of:
1. "example" organizational unit (group)
2. "example-repository" that belongs to "example" ou
3. empty "example-project" that belongs to "example-repository"

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Maciej Swiderski 2013-09-20 06:08:08 EDT
new configuration option has been introduced that allows to start business central with example configuration. To enable it following system property needs to be set:
-Dorg.kie.example=true

please note that this property and org.kie.demo are exclusive meaning only on of them can be set to true, so to have example setup active demo needs to be switched off:

-Dorg.kie.demo=false
-Dorg.kie.example=true

Commits in jbpm-console
master
https://github.com/droolsjbpm/jbpm-console-ng/commit/c414f22923e9e7e734ab8acf800a58373bace0b0
6.0.x
https://github.com/droolsjbpm/jbpm-console-ng/commit/69046c488c6bbd14d0324a4fa03732182ceb210a


Commits in kie-wb
master
https://github.com/droolsjbpm/kie-wb-distributions/commit/f112e4a4468f79c02102245c0105f4204d52a5ae

6.0.x
https://github.com/droolsjbpm/kie-wb-distributions/commit/e6b2a81ab7c61a9cd01b22b5838ba17739149f78
Comment 3 Maciej Swiderski 2013-09-20 06:09:43 EDT
Ryan, could you please enable it for the product as it was requested?
Comment 4 Ryan Zhang 2013-09-20 07:36:53 EDT
Thanks, Maciej. 
Done.
Comment 5 Joe Sniezek 2013-09-27 10:50:43 EDT
Hi, the idea of a built-in sample project sounds good, and we have recommendations for the names used in the project:

Instead of:
example
example_repository
example_project

Use:
example
repository1
project1
Comment 6 Maciej Swiderski 2013-10-03 06:15:41 EDT
taking it back to apply new names for repository and project
Comment 10 Tomas Livora 2013-12-02 07:29:29 EST
Maciej, in your comments above you have mentioned that org.kie.example property needs to be set true to create an example configuration. But this property is enabled by default in the standalone.xml. Is it an intended behaviour? Would not it be better if there were no repositories by default?
Comment 11 Maciej Swiderski 2013-12-02 07:36:14 EST
Tomas,

I believe this is the way product team decided to configure it by default - to enable example repository for product while disabling those coming from github.

Ryan, might be set person to confirm that.
Comment 12 Tomas Livora 2013-12-02 08:47:29 EST
Ryan, could you confirm that?
Comment 14 Tomas Livora 2013-12-04 03:33:48 EST
Verified on BPMS 6.0.0.ER5

Note You need to log in before you can comment on or make changes to this bug.