Bug 1010234 - [RHSC] Do not show rebalance in the Tasks tab until it has actually been started
[RHSC] Do not show rebalance in the Tasks tab until it has actually been started
Status: CLOSED DUPLICATE of bug 1021814
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: Kanagaraj
Shruti Sampat
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-20 06:27 EDT by Shruti Sampat
Modified: 2016-04-18 06:06 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-25 06:16:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shruti Sampat 2013-09-20 06:27:35 EDT
Description of problem:
------------------------
When rebalance is started on a volume, the Rebalance -> Start button remains enabled for a while, but the task starts appearing in the Tasks tab at the bottom of the page.

Either the button should be disabled once rebalance is started, or the task should appear only once the rebalance is truly started (i.e. when the Start button is disabled)

Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.4.0-0.2.master.20130911113322.gite7ade4a.fc19 

How reproducible:
Always

Steps to Reproduce:
1. Start rebalance on a volume from the Console.

Actual results:
The Rebalance -> Start button remains active for a while but the tasks appears at the bottom.

Expected results:
Either the button should be disabled once rebalance is started, or the task should appear only once the rebalance is truly started (i.e. when the Start button is disabled)

Additional info:
Comment 2 Dusmant 2013-10-25 06:16:15 EDT

*** This bug has been marked as a duplicate of bug 1021814 ***

Note You need to log in before you can comment on or make changes to this bug.