Bug 1010268 - hypervkvpd using wrong directory for its tools
hypervkvpd using wrong directory for its tools
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hyperv-daemons (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tomáš Hozza
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-20 08:15 EDT by Sitsofe Wheeler
Modified: 2013-10-02 02:55 EDT (History)
1 user (show)

See Also:
Fixed In Version: hyperv-daemons-0-0.2.20130826git.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1010280 (view as bug list)
Environment:
Last Closed: 2013-10-02 02:55:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sitsofe Wheeler 2013-09-20 08:15:43 EDT
Description of problem:
hypervkvpd complains that it can't find it's ancillary tools.

Version-Release number of selected component (if applicable):
0.1.20130826git.fc19

How reproducible:
Reproducible every time.

Steps to Reproduce:
1. yum install hypervkvpd.x86_64
2. systemctl enable hypervkvpd.service
3. systemctl start hypervkvpd.service
4. systemctl status hypervkvpd.service

Actual results:
hypervkvpd.service - Hyper-V KVP daemon
   Loaded: loaded (/usr/lib/systemd/system/hypervkvpd.service; enabled)
   Active: active (running) since Fri 2013-09-20 13:14:07 BST; 4s ago
 Main PID: 1840 (hypervkvpd)
   CGroup: name=systemd:/system/hypervkvpd.service
           └─1840 /usr/sbin/hypervkvpd

Sep 20 13:14:07 localhost systemd[1]: Started Hyper-V KVP daemon.
Sep 20 13:14:07 localhost KVP[1840]: KVP starting; pid is:1840
Sep 20 13:14:11 localhost hypervkvpd[1840]: sh: /usr/libexec/hypervkvpd/hv_get_dns_info: No such file or directory
Sep 20 13:14:11 localhost hypervkvpd[1840]: sh: /usr/libexec/hypervkvpd/hv_get_dhcp_info: No such file or directory
Sep 20 13:14:11 localhost hypervkvpd[1840]: sh: /usr/libexec/hypervkvpd/hv_get_dns_info: No such file or directory
Sep 20 13:14:11 localhost hypervkvpd[1840]: sh: /usr/libexec/hypervkvpd/hv_get_dhcp_info: No such file or directory


Expected results:
No errors about missing files.

Additional info:
The files are actually in /usr/libexec/hyperv-daemons/ .
Comment 1 Fedora Update System 2013-09-20 09:10:49 EDT
hyperv-daemons-0-0.2.20130826git.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/hyperv-daemons-0-0.2.20130826git.fc18
Comment 2 Fedora Update System 2013-09-20 09:12:31 EDT
hyperv-daemons-0-0.2.20130826git.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/hyperv-daemons-0-0.2.20130826git.fc19
Comment 3 Fedora Update System 2013-09-21 04:35:54 EDT
Package hyperv-daemons-0-0.2.20130826git.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hyperv-daemons-0-0.2.20130826git.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17317/hyperv-daemons-0-0.2.20130826git.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-10-02 02:54:23 EDT
hyperv-daemons-0-0.2.20130826git.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2013-10-02 02:55:56 EDT
hyperv-daemons-0-0.2.20130826git.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.