Bug 1010356 - Kernel 3.11.1-200.fc19.x86_64 does not boot with Xen 4.2.3
Kernel 3.11.1-200.fc19.x86_64 does not boot with Xen 4.2.3
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-20 11:16 EDT by Joseph Perrin
Modified: 2014-01-06 08:45 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-06 08:45:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is my /etc/grub.d/20_linux_xen file. (10.11 KB, application/x-shellscript)
2013-09-20 11:16 EDT, Joseph Perrin
no flags Details
Grub config file /boot/grub2/grub.cfg (18.75 KB, text/plain)
2013-11-24 16:09 EST, Joseph Perrin
no flags Details

  None (edit)
Description Joseph Perrin 2013-09-20 11:16:23 EDT
Created attachment 800531 [details]
This is my /etc/grub.d/20_linux_xen file.

Description of problem: Selecting Xen with Kernel 3.11.1-200.fc19.x86_64 causes reboot after initial display.

Version-Release number of selected component (if applicable):
Kernel 3.11.1-200.fc19.x86_64

How reproducible: Every boot

Steps to Reproduce:
1. Boot
2. Select Xen.
3. Wait for the fun.

Actual results: Automatic Reboot


Expected results: A running system with Xen


Additional info:
Installed F19 a couple of weeks ago.  A tempestuous install.  :-(  Realized I needed more disk after two weeks.  Had to glue things together to save configs, etc.  Initially Linux did not boot with uefi.  (There's little documentation on how that works exactly.)  I suspect my grub module args might be dodgy.  Several new kernel versions via yum, but this one doesn't seem to play nice.
Comment 1 Josh Boyer 2013-09-25 15:25:52 EDT
Can you attach some output from the failing boot?  Does it panic and reboot, or does it just reboot?  Does the kernel ever get started at all?  Can you attach your actual grub configuration file instead of the script?
Comment 2 Michele Baldessari 2013-11-24 06:41:00 EST
Hi Joseph,

can you please provide the infos asked by Josh in comment 1? Otherwise there
is just not enough info to go on.

thanks,
Michele
Comment 3 Joseph Perrin 2013-11-24 16:09:06 EST
Created attachment 828430 [details]
Grub config file  /boot/grub2/grub.cfg
Comment 4 Joseph Perrin 2013-11-24 16:22:38 EST
There are two lines of the initial boot screen displayed and then the screen goes blank and reboots.  (Can't reboot right now.)  The same thing has been happening with subsequent kernels.

I think I've found a common thread.  I purchased the exact same mb,cpu,ram at work, for two machines, and it does the same thing there.  You'll have to let me know exactly what information you want regarding the hardware, but here's an overview:


# dmidecode
# dmidecode 2.12
# SMBIOS entry point at 0x000f04c0
SMBIOS 2.7 present.
28 structures occupying 1546 bytes.
Table at 0x000EE880.

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
	Vendor: American Megatrends Inc.
	Version: P1.30
	Release Date: 05/08/2013
	Address: 0xF0000
	Runtime Size: 64 kB
	ROM Size: 8192 kB
	Characteristics:
		PCI is supported
		BIOS is upgradeable
		BIOS shadowing is allowed
		Boot from CD is supported
		Selectable boot is supported
		BIOS ROM is socketed
		EDD is supported
		5.25"/1.2 MB floppy services are supported (int 13h)
		3.5"/720 kB floppy services are supported (int 13h)
		3.5"/2.88 MB floppy services are supported (int 13h)
		Print screen service is supported (int 5h)
		8042 keyboard services are supported (int 9h)
		Serial services are supported (int 14h)
		Printer services are supported (int 17h)
		ACPI is supported
		USB legacy is supported
		BIOS boot specification is supported
		Targeted content distribution is supported
		UEFI is supported
	BIOS Revision: 4.6

Handle 0x0001, DMI type 1, 27 bytes
System Information
	Manufacturer: To Be Filled By O.E.M.
	Product Name: To Be Filled By O.E.M.
	Version: To Be Filled By O.E.M.
	Serial Number: To Be Filled By O.E.M.
	UUID: 03000200-0400-0500-0006-000700080009
	Wake-up Type: Power Switch
	SKU Number: To Be Filled By O.E.M.
	Family: To Be Filled By O.E.M.

Handle 0x0002, DMI type 2, 15 bytes
Base Board Information
	Manufacturer: ASRock
	Product Name: Z87 Extreme4
	Version:                       
	Serial Number: E80-35016600675
	Asset Tag:                       
	Features:
		Board is a hosting board
		Board is replaceable
	Location In Chassis:                       
	Chassis Handle: 0x0003
	Type: Motherboard
	Contained Object Handles: 0

Handle 0x0003, DMI type 3, 22 bytes
Chassis Information
	Manufacturer: To Be Filled By O.E.M.
	Type: Desktop
	Lock: Not Present
	Version: To Be Filled By O.E.M.
	Serial Number: To Be Filled By O.E.M.
	Asset Tag: To Be Filled By O.E.M.
	Boot-up State: Safe
	Power Supply State: Safe
	Thermal State: Safe
	Security Status: None
	OEM Information: 0x00000000
	Height: Unspecified
	Number Of Power Cords: 1
	Contained Elements: 0
	SKU Number: To be filled by O.E.M.

Handle 0x0004, DMI type 9, 17 bytes
System Slot Information
	Designation: PCI1
	Type: 32-bit PCI
	Current Usage: In Use
	Length: Long
	ID: 1
	Characteristics:
		3.3 V is provided
		Opening is shared
		PME signal is supported
	Bus Address: ffff:05:00.0

Handle 0x0005, DMI type 9, 17 bytes
System Slot Information
	Designation: PCI2
	Type: 32-bit PCI
	Current Usage: In Use
	Length: Long
	ID: 2
	Characteristics:
		3.3 V is provided
		Opening is shared
		PME signal is supported
	Bus Address: ffff:05:01.0

Handle 0x0006, DMI type 9, 17 bytes
System Slot Information
	Designation: PCIE1
	Type: x1 PCI Express
	Current Usage: In Use
	Length: Long
	ID: 17
	Characteristics:
		3.3 V is provided
		Opening is shared
		PME signal is supported
	Bus Address: ffff:03:00.0

Handle 0x0007, DMI type 9, 17 bytes
System Slot Information
	Designation: PCIE2
	Type: x16 PCI Express
	Current Usage: Available
	Length: Long
	ID: 18
	Characteristics:
		3.3 V is provided
		Opening is shared
		PME signal is supported

Handle 0x0008, DMI type 9, 17 bytes
System Slot Information
	Designation: PCIE3
	Type: x1 PCI Express
	Current Usage: Available
	Length: Long
	ID: 19
	Characteristics:
		3.3 V is provided
		Opening is shared
		PME signal is supported

Handle 0x0009, DMI type 9, 17 bytes
System Slot Information
	Designation: PCIE4
	Type: x8 PCI Express
	Current Usage: Available
	Length: Long
	ID: 20
	Characteristics:
		3.3 V is provided
		Opening is shared
		PME signal is supported

Handle 0x000A, DMI type 9, 17 bytes
System Slot Information
	Designation: PCIE5
	Type: x4 PCI Express
	Current Usage: Available
	Length: Long
	ID: 21
	Characteristics:
		3.3 V is provided
		Opening is shared
		PME signal is supported

Handle 0x000B, DMI type 11, 5 bytes
OEM Strings
	String 1: To Be Filled By O.E.M.

Handle 0x000C, DMI type 24, 5 bytes
Hardware Security
	Power-On Password Status: Disabled
	Keyboard Password Status: Disabled
	Administrator Password Status: Disabled
	Front Panel Reset Status: Disabled

Handle 0x000D, DMI type 32, 20 bytes
System Boot Information
	Status: No errors detected

Handle 0x000E, DMI type 7, 19 bytes
Cache Information
	Socket Designation: CPU Internal L1
	Configuration: Enabled, Not Socketed, Level 1
	Operational Mode: Write Back
	Location: Internal
	Installed Size: 256 kB
	Maximum Size: 256 kB
	Supported SRAM Types:
		Unknown
	Installed SRAM Type: Unknown
	Speed: Unknown
	Error Correction Type: Single-bit ECC
	System Type: Other
	Associativity: 8-way Set-associative

Handle 0x000F, DMI type 4, 42 bytes
Processor Information
	Socket Designation: CPUSocket
	Type: Central Processor
	Family: Core i7
	Manufacturer: Intel
	ID: C3 06 03 00 FF FB EB BF
	Signature: Type 0, Family 6, Model 60, Stepping 3
	Flags:
		FPU (Floating-point unit on-chip)
		VME (Virtual mode extension)
		DE (Debugging extension)
		PSE (Page size extension)
		TSC (Time stamp counter)
		MSR (Model specific registers)
		PAE (Physical address extension)
		MCE (Machine check exception)
		CX8 (CMPXCHG8 instruction supported)
		APIC (On-chip APIC hardware supported)
		SEP (Fast system call)
		MTRR (Memory type range registers)
		PGE (Page global enable)
		MCA (Machine check architecture)
		CMOV (Conditional move instruction supported)
		PAT (Page attribute table)
		PSE-36 (36-bit page size extension)
		CLFSH (CLFLUSH instruction supported)
		DS (Debug store)
		ACPI (ACPI supported)
		MMX (MMX technology supported)
		FXSR (FXSAVE and FXSTOR instructions supported)
		SSE (Streaming SIMD extensions)
		SSE2 (Streaming SIMD extensions 2)
		SS (Self-snoop)
		HTT (Multi-threading)
		TM (Thermal monitor supported)
		PBE (Pending break enabled)
	Version: Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz
	Voltage: 1.2 V
	External Clock: 100 MHz
	Max Speed: 3800 MHz
	Current Speed: 3500 MHz
	Status: Populated, Enabled
	Upgrade: Socket BGA1155
	L1 Cache Handle: 0x000E
	L2 Cache Handle: 0x0010
	L3 Cache Handle: 0x0011
	Serial Number: Not Specified
	Asset Tag: Fill By OEM
	Part Number: Fill By OEM
	Core Count: 4
	Core Enabled: 4
	Thread Count: 8
	Characteristics:
		64-bit capable

Handle 0x0010, DMI type 7, 19 bytes
Cache Information
	Socket Designation: CPU Internal L2
	Configuration: Enabled, Not Socketed, Level 2
	Operational Mode: Write Back
	Location: Internal
	Installed Size: 1024 kB
	Maximum Size: 1024 kB
	Supported SRAM Types:
		Unknown
	Installed SRAM Type: Unknown
	Speed: Unknown
	Error Correction Type: Single-bit ECC
	System Type: Unified
	Associativity: 8-way Set-associative

Handle 0x0011, DMI type 7, 19 bytes
Cache Information
	Socket Designation: CPU Internal L3
	Configuration: Enabled, Not Socketed, Level 3
	Operational Mode: Write Back
	Location: Internal
	Installed Size: 8192 kB
	Maximum Size: 8192 kB
	Supported SRAM Types:
		Unknown
	Installed SRAM Type: Unknown
	Speed: Unknown
	Error Correction Type: Single-bit ECC
	System Type: Unified
	Associativity: 16-way Set-associative

Handle 0x0012, DMI type 16, 23 bytes
Physical Memory Array
	Location: System Board Or Motherboard
	Use: System Memory
	Error Correction Type: None
	Maximum Capacity: 32 GB
	Error Information Handle: Not Provided
	Number Of Devices: 4

Handle 0x0013, DMI type 17, 34 bytes
Memory Device
	Array Handle: 0x0012
	Error Information Handle: Not Provided
	Total Width: Unknown
	Data Width: Unknown
	Size: No Module Installed
	Form Factor: DIMM
	Set: None
	Locator: ChannelA-DIMM0
	Bank Locator: BANK 0
	Type: Unknown
	Type Detail: None
	Speed: Unknown
	Manufacturer: [Empty]
	Serial Number: [Empty]
	Asset Tag: 9876543210
	Part Number: [Empty]
	Rank: Unknown
	Configured Clock Speed: Unknown

Handle 0x0014, DMI type 17, 34 bytes
Memory Device
	Array Handle: 0x0012
	Error Information Handle: Not Provided
	Total Width: Unknown
	Data Width: Unknown
	Size: No Module Installed
	Form Factor: DIMM
	Set: None
	Locator: ChannelA-DIMM1
	Bank Locator: BANK 1
	Type: Unknown
	Type Detail: None
	Speed: Unknown
	Manufacturer: [Empty]
	Serial Number: [Empty]
	Asset Tag: 9876543210
	Part Number: [Empty]
	Rank: Unknown
	Configured Clock Speed: Unknown

Handle 0x0015, DMI type 17, 34 bytes
Memory Device
	Array Handle: 0x0012
	Error Information Handle: Not Provided
	Total Width: 64 bits
	Data Width: 64 bits
	Size: 8192 MB
	Form Factor: DIMM
	Set: None
	Locator: ChannelB-DIMM0
	Bank Locator: BANK 2
	Type: DDR3
	Type Detail: Synchronous
	Speed: 1333 MHz
	Manufacturer: Kingston
	Serial Number: 11522013
	Asset Tag: 9876543210
	Part Number: KHX1600C10D3/8GX  
	Rank: 2
	Configured Clock Speed: 1333 MHz

Handle 0x0016, DMI type 20, 35 bytes
Memory Device Mapped Address
	Starting Address: 0x00000000000
	Ending Address: 0x001FFFFFFFF
	Range Size: 8 GB
	Physical Device Handle: 0x0015
	Memory Array Mapped Address Handle: 0x0019
	Partition Row Position: 1
	Interleave Position: 1
	Interleaved Data Depth: 1

Handle 0x0017, DMI type 17, 34 bytes
Memory Device
	Array Handle: 0x0012
	Error Information Handle: Not Provided
	Total Width: 64 bits
	Data Width: 64 bits
	Size: 8192 MB
	Form Factor: DIMM
	Set: None
	Locator: ChannelB-DIMM1
	Bank Locator: BANK 3
	Type: DDR3
	Type Detail: Synchronous
	Speed: 1333 MHz
	Manufacturer: Kingston
	Serial Number: 12526213
	Asset Tag: 9876543210
	Part Number: KHX1600C10D3/8GX  
	Rank: 2
	Configured Clock Speed: 1333 MHz

Handle 0x0018, DMI type 20, 35 bytes
Memory Device Mapped Address
	Starting Address: 0x00200000000
	Ending Address: 0x003FFFFFFFF
	Range Size: 8 GB
	Physical Device Handle: 0x0017
	Memory Array Mapped Address Handle: 0x0019
	Partition Row Position: 1
	Interleave Position: 1
	Interleaved Data Depth: 1

Handle 0x0019, DMI type 19, 31 bytes
Memory Array Mapped Address
	Starting Address: 0x00000000000
	Ending Address: 0x003FFFFFFFF
	Range Size: 16 GB
	Physical Array Handle: 0x0012
	Partition Width: 4

Handle 0x001C, DMI type 131, 64 bytes
OEM-specific Type
	Header and Data:
		83 40 1C 00 31 00 00 00 00 00 00 00 00 00 00 00
		F8 00 44 8C 00 00 00 00 01 00 00 00 00 00 09 00
		41 05 02 00 00 00 00 00 C8 00 3B 15 00 00 00 00
		00 00 00 00 26 00 00 00 76 50 72 6F 00 00 00 00

Handle 0x001E, DMI type 127, 4 bytes
End Of Table
Comment 5 Michele Baldessari 2013-11-24 17:04:49 EST
Hi,

you can remove 'rhgb quiet' from the grub menu and then start the machine 
under xen. If you can't take the logs because it crashes/reboots right away try taking a picture of the errors.

thanks,
Michele
Comment 6 Michele Baldessari 2013-12-25 13:56:24 EST
Hi Joseph,

can you try removing 'rhgb quiet' and get a picture of the oops at boot?

Also does a later 3.12.x kernel work?

Thanks and regards,
Michele
Comment 7 Joseph Perrin 2013-12-26 09:36:30 EST
My apologies for the delay.

I did the following:

-A newer kernel, (3.11.9-200.fc19.x86_64), was installed by yum.
-I removed rhgb quiet, and ran grub2-mkconfig.

The latest kernel successfully booted with Xen.

Was it the new kernel or the rebuilding the grub2 config?
Comment 8 Michele Baldessari 2013-12-26 13:17:06 EST
Hi Joseph,

either the new kernel or something else. the grub2 config 'rhgb quiet' only
controls some output to the console so it has no impact here.

Well, if things work now, maybe wait a bit (a week or so) to be 100% sure that 
it is fixed and then go ahead and close it.

Kind regards.
Michele
Comment 9 Josh Boyer 2014-01-06 08:45:28 EST
Please reopen if you see this again.

Note You need to log in before you can comment on or make changes to this bug.