Bug 1010422 - Only 3 Windows QXL displays in Windows7x86 VM when 4 are configured.
Only 3 Windows QXL displays in Windows7x86 VM when 4 are configured.
Status: CLOSED DUPLICATE of bug 1017217
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Virt Viewer Maint
Virtualization Bugs
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-20 14:35 EDT by Bill Sanford
Modified: 2013-10-09 11:57 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-09 11:57:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the virt-viewer 4 and the Windows 3 displays. (2.23 MB, image/png)
2013-09-20 14:35 EDT, Bill Sanford
no flags Details

  None (edit)
Description Bill Sanford 2013-09-20 14:35:28 EDT
Created attachment 800607 [details]
Screenshot of the virt-viewer 4 and the Windows 3 displays.

Description of problem:
Windows only sees 3 displays with the "-vga qxl -device qxl -device qxl -device qxl" that will configure 4 displays for the VM. See complete set-up text in the "Additional Info."

If I use virt-viewer to add the 4th display, it will add it from the "View" part of the virt-viewer menu.

In the attachment, you can see the four displays in the virt-viewer menu and only the three of the QXL in windows. 

Version-Release number of selected component (if applicable):
virt-viewer-0.5.6-7.el6.x86_64
rhev-guest-tools-iso-3.3-5.noarch.rpm
RHEL6.5-20130912.n.2
rhev-hypervisor6-6.5-20130910.2.el6ev.noarch.rpm
Windows 7x86 VM

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

/usr/libexec/qemu-kvm -m 2048 -spice port=3001,disable-ticketing,addr=127.0.0.1,seamless-migration=on -vga qxl -device qxl -device qxl -device qxl -global qxl-vga.vram_size=67108864 -device virtio-serial -chardev spicevmc,id=vdagent,name=vdagent -device virtserialport,chardev=vdagent,name=com.redhat.spice.0 -chardev spicevmc,name=usbredir,id=usbredirchardev1 -device usb-redir,chardev=usbredirchardev1,id=usbredirdev1,debug=3,filter='0x08:-1:-1:-1:1|-1:-1:-1:-1:0' -readconfig /etc/qemu/ich9-ehci-uhci.cfg /home/images/Win7x86.img -monitor stdio 

/usr/libexec/qemu-kvm -m 2048 -spice port=3002,disable-ticketing,addr=127.0.0.1,seamless-migration=on -vga qxl -device qxl -device qxl -device qxl -global qxl-vga.vram_size=67108864 -device virtio-serial -chardev spicevmc,id=vdagent,name=vdagent -device virtserialport,chardev=vdagent,name=com.redhat.spice.0 -chardev spicevmc,name=usbredir,id=usbredirchardev1 -device usb-redir,chardev=usbredirchardev1,id=usbredirdev1,debug=3,filter='0x08:-1:-1:-1:1|-1:-1:-1:-1:0' -readconfig /etc/qemu/ich9-ehci-uhci.cfg /home/images/Win7x86.img -monitor stdio -incoming tcp:127.0.0.1:4444 

remote-viewer spice://127.0.0.1?port=3001
Comment 2 Tomas Jamrisko 2013-10-09 11:57:51 EDT
Closing this issue as DUPLICATE as:
a) it was reported later
b) it's not really an issue with virt-viewer, nor guest-tools, as both work properly with an older version of qemu-kvm

*** This bug has been marked as a duplicate of bug 1017217 ***

Note You need to log in before you can comment on or make changes to this bug.